SketchUp Model went blank, can only see background, can't zoom, orbit or do anything else

I was working on a model in TrimbleConnect, and suddenly the model disappeared, as well as the axes.

My first thought was that I had zoomed in past the model, so I tried zooming out. I selected the Orbit tool and tried to find the model that way, but the orbit tool is not working either. Then I noticed that none of the tools were working, at all. The pencil icon was always the cursor, with a small white rectangle next to it, regardless of which tool I chose.

I also tried selecting and placing the components I had created, but nothing at all happens when I do so. The cursor doesn’t have the component attached to it, and the screen remains blank.

I’ve searched at least a dozen threads, tried several suggested solutions, but nothing seems to have any effect, whatsoever.

If I can export my components and start a new model, that would be a pain, but it would be better than losing all my work. I’ve put several hours into this model, so I’d be sort of crestfallen if there’s no way to get it back.

Any help would be greatly appreciated!

In future always have at least one scene saved that had focus on the model to return to.
You might be zoomed out way too much. Lines you draw are too small to see, as wth components attached to your cursor or when placed. (the rectangle as cursor for a Line tool though is strange).
You could return to that scene if created.
What happens with using ‘Zoom Extents’?
Try copy all and then ‘Paste in place’ in another opened SketchUp instance.

1 Like

Thanks so much for your reply. Zoom Extents didn’t seem to have any effect, and unfortunately, I didn’t know about Scenes until just now. I haven’t really used SketchUp for many years.

I was able to “select all” and then copy/paste into another instance, but I can’t interact with the model after pasting it. It seemed to paste the entire model as one object/component, minus one layer, into the new SketchUp instance. It seems somehow locked from selecting or editing in any way. The contextual menu doesn’t show up when I try to right-click on it. Any thoughts or ideas on that?

Does the model turn red when you click on it. If so, you have a locked component.
Right click on it and select UNLOCK.
The resulting entity is still a component and should turn blue when clicked on.
Double click on it to edit or Right click > explode.

It just sounds like some Javascript had a problem. If you have developer tools on your browser you could see what errors are going on.

The web app stores what you’re doing locally. If your browser crashed you should be offered a chance to reopen your unsaved model. That feature is browser specific, and you only seem to get one chance of reopening the model, but it might give you back your progress.

Thanks for all the suggestions.
@cakrupp , When I paste the model into the new instance, the cursor cannot interact with it at all, so I can’t even select it, unfortunately.

@colin, I’m a front-end developer by trade - so I looked at the console errors. There are a bunch of webgl render warnings having to do with textures not loading, a couple doubleclick ads that are returning 404s, and another marketing tracking code that’s not loading.

All of these warnings and errors are also showing up in the console on new instances I create, which function fine. So, I imagine these errors aren’t the problem.

Here are the webgl errors:
1 of this warning:
WebGL: INVALID_ENUM: getParameter: invalid parameter name

22 of these:
[.WebGL-0x7fd50d9a6800]RENDER WARNING: there is no texture bound to the unit 2

17 of these:
[.WebGL-0x7fd50d9a6800]RENDER WARNING: there is no texture bound to the unit 0

Maybe try doing a “Save As” to a different name rather than cut/paste.

Open the new file and see if anything is better.

Just a thought. Sometimes this works to fix an f’d up model.

Also, I was attempting to do a “Ctrl A” or “Edit > select all” to pick the object without using the cursor. That part works.

I was hoping to find an “explode” command in the pull down menus but couldn’t seem to find one except in the context menu.

It’s the web version of SketchUp, I don’t think it has a Save As.

See if you can get your hands on a regular copy of SU Make 2017 or 2018. Can be had at Sketchup.com/downloads/all
I’d install one of these. Make sure you select the MAKE version and not PRO.

Maybe this will work, better than the web version anyway.

@cakrupp and @colin - yeah, this is the web app, not the desktop app.

I exported the skp file and opened it in the desktop app (2017, make). No luck with that either.

EDIT: I tried doing the same thing on the desktop app that I’d tried earlier on the web app, and it worked:

  • Opened the file in SketchUp make 2017
  • Select All
  • Copy
  • File > New
  • Paste

Then I was able to orbit around, find the model, Select All, and Explode the model

SECOND EDIT:
Anyone who has a similar issue - Exploding the model was not very helpful, because it exploded the entire thing into surfaces and lines, not into components. I ended up having to reconstruct the model from the components, which were in the .skp file that I had exported from the web app. It took a couple hours but at least I didn’t have to start from scratch.

Thanks again for helping me out with this.

Happy to hear that things work out now.
Have you created that first scene yet?

Unfortunately I don’t know much about the web version but if you install 2017 or 2018 Make (free) and can open your file from there you can then right click on any component and select “save as” to save it elsewhere in your PC.
Maybe that’s available in the web version as well.

You might also find the Sketchup YouTube channel and post a request for a solution to your issue on any of Aaron’s videos, which is most of them.

He’s the SU solution and how to guy at Sketchup.

There is no 2018 Make version.

Yes - as soon as I had the shell of my model rebuilt, I created a scene! I’ll make Scenes part of my SketchUp workflow moving forward.

Glad we somehow found our way. I’d stay away from the web version. It’s missing a lot of functionality found in the main program.
Unfortunately it will be the only free version from now on.

I’m very relieved I was able to get the model back. I’ll definitely avoid the web app moving forward, and I’ll be using the Scenes functionality from now on. The only reason I used the web app in the first place was because I went to re-download the desktop app, and it looked at first as though it was no longer supported. the 2017 “make” version still works great though!

Just so you are aware, making scenes does not save the model itself, only a few aspects such as camera location(view), layer states, etc. It does help you get back to a place you know if you soin out of control (lol).
Always save your model in a timely manner.
Look at the bottom of the Scenes manager panel to see what aspects are saved when you make or update a scene.
Chris