SketchUp Model Size Reduction

resize
modeling
unity

#1

Hi everyone,

I’m new to Sketchup, and I’m having some issues with using skp files in Unity. With the skp files I’m currently using, I can only import 4-5 files into Unity at once, whereas I actually need to import 12-13 files. When I import more than 4-5 files, Unity crashes.

I’ve tried reducing the skp file size by using the CleanUp extension and purging, but neither of those have made a difference. My next guess is the the poly count is too high, but I’m not even sure how to verify this. Also, is there a way to do poly reduction for skp files? I’ve only found ways for STL and OBJ files (like Meshlab). I’d like to keep the skp file format since I need to import this into Unity.

Thanks!


#2

Hi @ohlala191785 ,

You can check your polygon (face) count via Window > Model Info > Statistics .

This article might be useful which explains “Making a detailed model in a lightweight way”: https://help.sketchup.com/en/article/3000310

and this: “How to model efficiently using existing 2D and 3D sources” https://help.sketchup.com/en/article/3000311


#3

In Unity you can have it merge coplanar faces, and there are a few levels of mesh compression. Perhaps that would help.

The other option would be to export as Collada, then use Meshlab on that file.


#4

This topic was automatically closed after 91 days. New replies are no longer allowed.