Sketchup in Unity

I try to import Sketchup file in Unity, most part of SKP model is importing fine but there are some groups, dont import in Unity. What could be the reasson?

Post the model and tell us which groups are not importing.

Reversed faces?

No, not reversed. At first when i imported model ( it is one whole GROUP ) there were no part of ground. I checked it insketchup and saw that in this WHOLE group there were two kind of ground, one was GROUP In this whole GROUP and second one was just explained in this same WHOLE Group. so i make this second as a Group too. So i realized that explained faces is lost in Unity. But there is an other problem. In this WHOLE GROUP, (in this one, there are many groups and components) there is Group >>Group>>Group>>Group and it is not importing. But there are same principle groups and they are importing fine. I thought there is a principle of importing, which woudnot be 3x 4x or 5x Grouped. But dont know how this one works.
Model size is 1 GB, i can not upload it at this moment.
Hope i explained clearly.
Thanks Anssi

Upload it to Drop Box and share the link.

Okey, tommorow i will and post here. Thanks again

Something you could do is copy a mixture of groups that work and ones that don’t, into a new file. Test that file in Unity, and if the same groups fail, you would have a very small example file that we can check.

Okey. The first idea why i asked it here was that, is there any principle of importing sketchup to unity. I will come back tommorow, thanks.

Unity isn’t up to date on what SketchUp files it supports, but it should do fine with 2017 version files. Beyond that, you shouldn’t need to do anything special to make the import work. If you were using SketchUp Pro you might want to export as FBX, Unity likes those kind of files. But as you’re using SketchUp Make, either figure out the issue with your model, or you could try exporting as Collada, see if that works better.

If your SKP is 1 GB, the Collada file would be huge, so I’m hoping you figure out the problem and stay with SKP.

1 Like

Hello again, i checked all model… everything is importing fine and works, only this parti is not going in model (it is importing but not fully)
here is this little part
LINK >>> JGUPI ERROR.skp - Google Drive

i exploded it then make it GROUP again and now it imported but with full model it is not going :smiley: :face_with_spiral_eyes:

I see reversed faces on windows and a bunch of internal faces in the structure and holes in surfaces.

You might try cleaning up the internal faces and stray edges to see if that helps.

There’s also materials on back faces internally that may be problematic.

Windows are importing perfect and lottle details, only facade faces not going. Okey now i try to edit it and will try soon. Thanks

I am new in unity and if you know, when textures will be processed and will be ready materials for render, does models size change?

In your SketchUp model you have a lot of infinitely thin walls. That is, there is only one face, and programs such as Unity only draw front faces. You could solve that by modeling walls and floors to have some thickness, where each outward pointing face is a front face. The back faces would not be directly viewable. Maybe that is what is happening. Here is a screenshot of the imported model view from the front, and then from underneath. See how a lot of faces are missing.

A different solution would be to export as Collada, and in the options turn on the Export two-sided faces. What you get is the geometry as one file, and the materials as a folder of files. That seems to do better in Unity, you can look at faces from any direction, and the materials come in ok.

1 Like

I did everything perfectly and imported model very well. And thank you. I have one ask if you know please explain me… as i said i am new in unity. I created model in Sketchup, size is 800 mb. When i import model in Unity it works very very slow, FPS in PLAY time is 1 FPS. I have not idea why it works so slowly. Do you know any way how to fix it?
Thanks

Yes, take 799 MB away from the file size.
Joking aside, you have just discovered what the idea behind 3D games is: Make your model as simple as possible. Use textures instead of geometry whenever you can.

Annsi, yes it is good way to use textures but i have seen more detailed models with more size works perfectly. I think (i dont know maybe im wrong) that Sketchup file is not work perfectly in unity? I try to find the way to solve this problem. :pensive:

I believe performance in Unity is down to the number of meshes, and each SketchUp group or component may be a different mesh. I tried exploding your small model, and that may have helped, but it was still a lot of meshes. If you’re getting into coding in Unity you might make sense of how you can combine meshes.

1 Like

is this normal same primitive model is 114 mb? i purge unused

That file works fine for me in Unity, using the export as Collada option. Most of the file space is being taken up by your textures. You have two copies of one texture that are 11544x8038 in size. That may be too much for your GPU. Try replacing the existing image with this one.

1 Like