Sketchup model disappears from view when I try to Zoom In, Orbit, or Pan

My chiller model disappears from view when I try to Zoom In, Orbit, or Pan. I’m not sure if I’ve done something to my axes, perhaps?
chiller_v1.skp (887.8 KB)

Your model is located at a large distance from the SketchUp model origin. That will make it hard to work with. I suggest you apply the move tool to get it to the origin as follows:

  • activate the move tool
  • click on the lower left corner of the chiller and then move the mouse slightly
  • type [0,0,0] (the closing ] may be supplied automatically, depending on your version of SketchUp

The chiller will then be located at the origin. You can use zoom extents to bring it back into view.

Thank you! I will try that.

That worked bringing it back into view, thank you! Any ideas on why it disappears from view when I try to Pan?

I’m looking. There is something odd beyond just the distance to the origin in your model, but I haven’t nailed it down yet.

There is something corrupt buried in your model that makes it behave as if there is geometry very far from the origin. Feels like a version of the old text leader bug that would happen if the entity a label was attached to was erased, but I don’t think that is a problem any more? I’ve tried isolating it but it appears repeated inside many of the containers and I have not been able to find the specific problem yet. For now the only working version I have is this one in which all the geometry has been exploded. It’s not ideal for working with but it’s something.

chiller_v1 EXPLODED.skp (1.5 MB)

The device’s size is astronomical. 1.7 trillion kilometers
image

I’ve found the issue, but I don’t yet see a simple way to fix it. The chiller component definition is drawn at an immense size, and the instance in the model is scaled reciprocally to make it look normal in the model. That extreme contrast is driving SketchUp’s view nuts. I have to go run an errand now, but I’ll look again when I get back.

Thank you for your help! I did try to scale the model down after I realized I made it so huge. And I apparently messed it up in doing so.

Yes, blind eyes over here! I’m still learning to Zoom In instead of Scale up.

Thank you! This is at least something I can work with!

@slbaumgartner and @Anssi have found the right track. Open your original file, open the outliner, right click on the chiller-v1 component in the outliner, select Reset Scale. Fixed.

Thank you! That worked. Now I can move around the model again and my heart can stop racing! LOL.

1 Like

Fixed in the sense that the disappearance on pan doesn’t happen, but it is restored to the original immense size! Unless the thing is meant to be about 400000km long, there is still work to be done!

1 Like

Yes, sigh, I spoke too soon. Resetting the scale makes the file operational again, but it’s much too large. All my attempts to scale the geometry back down to an appropriate size without exploding all containers have brought back the problem. :frowning_face:

I forget the order I tried things (resetting scale, exploding to raw geometry etc) but this is the size that happened.
chiller_v1_2.skp (541.4 KB)
Now it is probably too small, the tubes are only 2 mm in diameter.

1 Like

Thank you, Anssi!

No worries. I was able to make it work with what you came up with when you exploded the geometry, so thank you!