Sketchup Model Disappeared and Crashing Computer

Hello!
My sketchup file refuses to show the model ive made despite loading other models completely fine. I cant draw in the file without it crashing yet the file itself still has substantial volume? Please Help!

  • A Desperate Student :frowning:

Your model is terribly bloated.
Using Model Info > Statistics > Purger Unused… removes ~80% of this…
After that it works fine for me…
Is this what you hope to see ?

I notice that several faces on the roof and the carparking are reversed, but this is just sloppy modelling unlikely to cause issues like you report…
Also, why is there a rogue bit of the building far below it ??

That’s exactly what I hoped to see. I’m very self taught when it comes to SketchUp (usually use ArchiCAD), so im not sure what it means to for faces to be reversed? This has probably been the source of problems in renders in the past. What does this mean and how do i stop doing it?

(Also the rouge building is a component, I planned on doing interior’s later on and editing it like this)

Reversed faces.
View you model using Monochrome mode.
You will see some faces are not ‘off-white’ but ‘blue-gray’.
You are seeing their backs.
To fix it select the face[s] with the problem and use the right-click > context-menu > Reverse faces…
The face will flip over, you might need to reapply the material to the front, if it was just on the back.
You’ll probably need to edit the group of component-instance containing the face[s] so that you can select the face and get the context-menu item…
I have a Shortcut key to do the face reversal, avoiding the context-menu clicks, to set that in Preferences you need to have a face preselected so a ‘Reverse’ entry appears…
To see more clearly which are your problem back-faces you could also change your Style settings so that the default back-material is more brightly colored and noticeable…

Exposed back-faces are particularly problematic for rendering and 3d printing.