SketchUp Make works for a short period then doesn't

I am running Windows 10 with a NVidia gforce 970. It seems as though I have to constantly uninstall and reinstall Sketchup make 2016 to allow it to function. This isn’t actually a new issue, but seemed to appear shortly after 2016 came out. I had been resorting to the reinstalling for several weeks after then actually got tired of it and started using fine graph paper. While I had wait for a fix. Essentially Sketchup will work for the first day or two after the install then freezes upon trying to start up, the program itself pops up as it should then it seems as though when it starts to load anything in the work area it freezes. By this I mean anything, including going straight from the primary executable shortcut. I had used 2014 and 2015 w/o any sort of problems and it seemed to work fine, but by the time it had started to give me trouble I no longer had a way to install the 2015 version. I have been trying to look up a fix for this particular problem, but have yet to come across one referencing similar issues so I am hoping to find something here as there is something I need to have 3d printed so graph paper wont cut it

Did you install SketchUp via right-click “Run as administrator” on the installer package ?

1 Like

This may be stating the obvious, but you should also run a virus scan to be sure that no malware is affecting the program’s operation (just to be on the safe side). It is typically considered beneficial to install and make frequent use of reliable digital security software any time a new program is introduced into your system.

1 Like

Have you tried updating your Nvidia driver? Typically, if your driver has problems with OpenGL, they will not show when you start SketchUp the first time after install, as SketcUp users OpenGL Hardware acceleration only at the second launch-


Ok So I do keep my drivers as up to date as they can be ( I have the software installed that notifies me when any drivers are released. Also do quite regular virus scans to ensure that my stuff is clean…I had actually also done the admin install on several occasions when the problem originally began as that was one of the recommendations to try then as well with no luck. However, it had been a while since I tried that method and there have obviously had numerous other software updates since that time so I did it once more when you had mentioned it (its been so long since tried to actually troubleshoot). Its been nearly 2 days and so far seems to be working properly but tomorrow will be the big test, if it still works then, I’ll be quite happy and hopefully it will stay that way

I need to stress to readers that the administrative install is not something that is recommended “to try”, … rather it is the proper method to install SketchUp, given by the Trimble team, on the SketchUp Help Center installation instruction page(s), for Windows editions.

It is also, since the release of Windows 6 (Vista and higher) with User Access Control (UAC) enabled, the necessary way to install the great majority of full software applications. Most especially those that are installed (into the %ProgramFiles% folders) so any user logging onto the workstation can use them.
So called “Apps” (applets from the MS Store) are a different animal, and install into the User %AppData% folders.

1 Like

Okay so I redid the admin install, on my admin account, and it worked for a little bit longer yes but now its back to doing the exact same thing as it was before.

SketchUp versions can be installed side-by-side on the same machine. They use different folders and settings.

Be sure that theNvidia GPU is set to be used with SketchUp via the Nvidia Control Panel.

AND, if you have problems with the 64-bit edition, uninstall and try the 32-bit edition.