Sketchup Make throws bugsplat when copying or push/pulling

I’ve been using Sketchup on and off for a number of years and usually have only done small projects. This past week I got a wild hair and decided to do something a little bigger; a full scale WTC Tower.

While I had no problems for the majority of the model, I’ve gotten to the point where, when trying to copy a small column I made to the top of the model, Sketchup constantly throws a bugsplat.

Notably, when working with the column down at ground elevation within the model (0ft or so), I can interact with the column piece just fine. Copy, paste, push/pull, mass copy operations all work.

So I tried to just remake the column manually up at the model elevation (~1300ft) and more frequently than not, trying to make the column via push/pull at that elevation also triggers the crash (so I’m assuming it actually has nothing to do with the column. :stuck_out_tongue: )

At this point I went through the model and cleaned out all the hidden geometry i could find (the rendering performance was getting fairly bad), and in doing so managed to reduce the edge count by 25,000. Still no luck, still getting crashes when working at the top of the model.

I’ve tried cleaning the model with extensions and validating the geometry, neither helped. Then I tried disabling all of my add-ons and when that still didn’t work I went through and deleted all the materials from my model as a test to see if that had anything to do with it (it didn’t). I copied the entire model and pasted it into a different file to see if the model file might have been corrupt. As a last resort I tried simply moving the model along the Y (blue?) axis so that the top of it was at roughly ground level to try and rule out the possibility of it being a problem with the sheer height I was working at. Still no go.

I’ve submitted probably 4-5 of the 20-some bugsplats now, though only one of which has my email address. I’m now stuck as I can’t seem to expand on the model without encountering the bugsplat. Hoping maybe someone can look at the dump file and provide some insight.

Is your graphics driver up-to-date?

Test existing driver. In SU, go to Window > Preferences > OpenGL and disable use hardware acceleration. Restart SU. Does SU splat now?

Plugins installed?

Did you install SU as an administrator?

Disabled Hardware Acceleration, still crashed when copying the component to top of model. Updated to latest driver version (372.70), still exhibiting same behavior.

Plugins installed are as follows:

  • Place Shapes Toolbar (Disabled)
  • CLF Center on Origin (Disabled)
  • STL Import & Export (Disabled)
  • Advanced Camera Tools (Pro Only)
  • Beizer Tool (Disabled)
  • Dynamic Components
  • Sandbox Tools (Disabled)
  • Trimble Connect (Pro Only)
  • Photo Textures (Disabled)
  • CleanUp3
  • TT_Lib2

Yes, SU was installed as Administrator.

Think I figured it out. Apparently SU must not have liked the way I sectioned off the columns from their backer wall before starting with that column piece. Deleted the whole section and redid it, now it seems to be working fine. Go figure. :slight_smile:

I glad you ‘fixed’ it, but your problem still seems odd. Your computer (graphics card) and extensions don’t throw out any red flags. If you had the original file that caused problems to share, some of us could poke around to check if anything was unusual.

Bugsplats record the occurrence of problems. It’s there to get a count and track problem. If there are a lot of the same problems, it bumps up that problem higher up on the list of things to fix. Keep sending them in. Your contact info means they can be found - which is handy for looking up problems specific to your computer through this forum.

Well I had “fixed it” but ended up running into the same problem again not too far later, in more places than I was expecting. One of the crashes actually opened a webpage with this information:

At this point i’m pretty much assuming the problems are on account of the way I’m modelling. I’m more than happy to provide the file if you want to take a look and have labeled a few problem points with explanations of the behavior needed to trigger the crash. The file, though, is too large to upload here (a little over 27mb… oops lol).

Hopefully you’re okay with Dropbox links: Model Download (via Dropbox)

I got the same bugsplats, and yeah, there are some modeling issues.

The crash report indicating a recursive component is odd as you are not using components - which you should be using instead raw geometry.

Among the many benefits of using components would be to reduce the file size. And in this file, model individual parts that repeat. Make that part a component then select the component and make a linear array using Move + Ctrl. Using a component instance with x number of copies creates a smaller file than one model with a goob of raw geometry.

For what you are modeling, the curves have too many segments. If you were using an array of components, this could easily be changed as editing one component changes all the copies of the same component.

The outer surface is a mix of front and back faces. Set up some Scenes. Save one Scene with face style Shaded with Texture. Save another Scene with the monochrome face style. This way you can quickly switch between styles. Mixing the outer surface with front and back faces will cause issues with rendering extensions and 3D printing. Another big benefit of having a Scene with monochrome face style is that SU renders it faster. Disabling edge endpoints and extensions also will speed up SU rendering. Make those changes and save them to the monochrome face Scene and disable saving the camera position.

Your component arrays will touch at places. To make that seam disappear, Hide the touching edges with Eraser+Shift and delete any touching faces.

I was able to get one of those pages attributing the crash to a recursive component, crash report #248482. The Face Me figure is the only component in the model. And the crash was from Push/Pulling, holding the tool over another face to infer and stop the tool to match the height of surrounding geometry.

Stopping the Push/Pulling below or above the target extrusion does not splat. Constructing the geometry by another method does not splat.

This is a bug.

Yeah, that was more or less the kind of behavior I was noticing (and thus having to work around to make the model look remotely “done”.)

A lot of helpful info there, as well. Appreciate all of it.

@Marc we have some bugsplats here claiming to be from recursive components but there’s no component activity - just some specific P/Ping.

Your crash doesn’t appear to be related to recursive components, but it is some sort of memory allocation error - which is most commonly caused by recursive components.

I’ll take a look at the file to see if I can dupe the issue here in the debugger.

You may want to try installing the 32-bit version of SketchUp just to see if it handles the memory any differently for this model.



Can confirm the model crashes SU 32-bit, doing so without triggering a Bugsplat, instead throwing the standard Windows “This application has stopped working” dialog.

Strangely, I couldn’t reproduce the bug on my Mac. Pushpulling the faces indicated by the leader text in your model worked…