Pasting Copying sloooooooooowwwwwwwwwwwwww

This is a bug that goes on for years and years and is getting worse.
When my model reaches a certain size and complexity (nothing insane, maybe 10 MB in size, 40-50 components, 10-12 tags in subfolders) it gets increasingly impossible to insert new components or copy -pasting any content. To insert a simple 2D-tree or 2D-person via component browser or by copy-paste may take 15 minutes (!!!) or not work at all.

W. T. F???

Is SketchUp/Trimble happy taking my money but obviously unable/unwilling to fix bugs or is this a feature I#m not aware of?

Your profile says you run macOS Mohave and “latest” SketchUp version (which should be 21.1.298 - please confirm that). I don’t know if there are any identified issues with running SU21 on Mohave, perhaps others can comment. @colin?

The file size can be a poor indicator of model complexity. What does Model Info->Statistics say about edge and face count?

What sort of extensions do you have installed? Perhaps one of them is overloading the system. If you have been using the same extensions for a while, that would be consistent with having this problem “for years and years”.

Open Activity Monitor and see whether SketchUp is saturating the CPU and also whether memory is overbooked.

That was quick…

SU Version 21.1.298 (freshly updated).
Well, of course I use several plugins, (some of them making SU useful in the first place - may I say “mirror tool”?) and that’s an idea, to switch most of them off.
Does the Plugin manager really kicks them out during runtime or do I have to restart SU?

Just tried to copy-paste within the same model that didn’t work yesterday and now it works like a charm. Didn’t do anything with plugins, just had the update.
There seems an issue with the time I run the app - the longer the slower it gets.
On the other hand the behaviour didn’t change after restarting the whole computer.

Did you look at the statistics in your model?

Also consider that the graphics card you list is rather old. As I understand it, newer versions of the Mac OS don’t really support those old Nvidia graphics cards. According to the various benchmark sites, the GT 750M is not a great performer. You might see about changing the power profile for your computer and make sure it is plugged into mains power. Running on battery can cause your computer to restrict power consumption by the graphics card.

Make sure you are also keeping your models cleaned up. Purge unused stuff from the Statistics window in Model Info.

That’s the video card I have. The model I currently have open is 119MB. I haven’t seen that bad a delay with copy and paste.

I believe MacOS out of necessity supports Nvidia cards that were original equipment with Apple hardware like MacBook Pros. I think the drop of support was for third party Nvidia cards that might be put into a Mac Pro.

1 Like

I think you have a variation of a problem people have seen, where downloading something from 3D Warehouse takes a long time, if you are downloading into a model that is already full of other components. My theory about it is that the incoming component has to be checked against the existing ones, to make sure that ID numbers don’t clash. Doing a copy and paste test into the document that already has gone through that delay wouldn’t be the same test.

Could you create two files, one with quite a few components in it, and another with a component that is not in the first model? Then try the copy and paste test.

If it is slow, can you say whether you have any custom component collections? The incoming component may be checked against those too.

I’m watching it now.
And frankly - for all of you who claim it’s a thing of the graphic card or my computer is too old or whatnot - stop right now. I’m using a 2014 MacBook Pro and I am running Photoshop and Blender and both programs are really snappy and fast, with Copy’n’paste and all, Blender even with rendering it’s kind of decent. It’s SU that carries around bugs for decades since it was fancier to implement new features than to iron out old bugs. And then it even cuts down the abilities: before SU 2021 I could exported picts up to 7,000 pixel wide (or maybe even wider, but I never tried). Not so anymore, no the limit is 5,000 pixels. Why? Is there any good reason behind that?

I have tons of custom components collections, that’s the whole point.
I did suspect a version of what you suggested and exploded all components, grouped the result and copied that. Didn’t work either.
I do still suspect the (TOTALLY CRAPPY; DOWNRIGHT UNUSABLE) materials browser, so I will have to try to delete all materials before I copy. But then again: what’s the fricking point in doing that?

To do the test you tried, you would also need to purge unused, because the non-exploded components are still around.

A test you can do yo see if it’s the component collection that causing some of the slowness, would be to close SketchUp and rename the Components folder. Open your heavy model and do the copy and paste test. Does it work quicker?

I just had a new idea. These IDs that I’m theorizing about didn’t exist a few versions ago. You could do similar tests in 2017 and not see any slowness. I wonder what would happen if all of your component collection had to be updated, to make sure they all had unique IDs.

The purging unused was to remove the components that are no longer in the scene. That it also gets rid of the materials doesn’t really affect the test. The reason to do the test is to see if you do have the problem that we have seen other people report, and any tests you can do could help us to find out what is causing the slowness.

Could you time how long it takes to paste, when all of the components are still there, and also time how long it takes when the components are not there?

Thanks Colin, you have a lot of good ideas. My problem is that this behaviour is hard to reproduce.
As I wrote earlier, for the moment it works snappy, within the model that made so many problems just hours ago…
I’m afraid I have to come back when these problems start to re-emerge again…

My findings with slow copy/pasting:
If I copy just geometry from one model and paste it into another is ok but…
If I copy geometry WITH multiple materials WITH maps/textures then the paste is slowwwww.

What I think is happening is that the materials have to be added to the models db, during the paste process they have to be:

  • Compared to all the existing mats to see if they are the same / new / same name but different,
  • Textures have to added to the models ‘database’ (or whatever it’s called)
  • If the mats are setup for rendering then there’s the additional bump, reflection etc info to be added.

If you have the materials panel visible I’ve seen it periodically flickering as new mats are added.

All this can slow a paste dramatically, I’ve often gone off to make a coffee during the paste process; it can take that long.

Copy-pasting something within the same model won’t have to do all the material processing as the mats are already in the model so will (If I’m right) be inherently faster.

I’ve knocked up an example, The WeTransfer link below is to a 25Mb SU2021 model. It’s Just a vase with a bunch of daffodils.
There are 2 versions in the SU file:

  • one with no textures whatsoever
  • the second with everything textured.

Try this: Open the attached model and copy the un-textured model and paste it into another SU file. Then do the same for the textured one.
You should see a massive difference in paste time.

Screenshot of what’s in the file:

I don’t know if it’s relevant for you but on my ancient win 7 I get 4 seconds and 19 seconds.

That ‘feels’ about the same ratio as I get, you can slow it further by copying them into an already heavily populated model

Very good ideas and there maybe several things going on (ID checking, material database, etc), but frankly: that’s pathetic for a professional app. I know freeware which is faster and more reliable.

Did I mention the the crappy materials browser? Did I mention basic functions missing (mirror tool?), did I mention language switching that doesn’t work?
Did I mention that Blender is freeware and is on par with Cinema4D or similar? The list goes on.

So it seems Trimble and the SU Team never really bothered to bring SU on a Pro level, they only cared to bring the pricing to a Pro level.

Yawwwwwwwn,
You ask about Copy-Paste, a possible answer as to why is posted and now you go on a rant about other ‘crappy’ things.
Yea yea yea, SketchUp is this SketchUp is that bla bla bla.

Off you go then and use these wonderful alternatives.

1 Like

So you think all is pink and swell?

I pay for SU since 2003. You could call me a loyal customer. I was even a public SU presenter before it was sold to Google.

I am trying to find a solution to at least bring SU to do what it’s supposed to do, to repair basic functionality. Problem is: SU is full of unresolved issues for more than a decade. And I feel as a paying customer I absolutely have the right to mention these problems.

Besides: what do you care if I rant?

And I’ve been since 2004.
The title of THIS post is ‘Pasting and Copying slooooooowwwwww’ hence my yawn at the change in subject once an explanation/reason/answer was posted.
There are many many posts where you can talk about how wonderful Blender or whatever is.

Don’t go thinking I’m a fanboy either, check my last line of this reply I made earlier Turn off new toggles - #53 by PaulRussam