SketchUp Make seems cause start up blue screen on Windows 10/Surface Pro 4


#1

As described in title, I have this problem and can not install SketchUp Make on my machine…


#2

Which version of SketchUp? Are you installing it as administrator?


#3

The newest version I can download from official website.


#4

I’ll ask again, Did you install as Administrator?


#5

Sorry for ignored. I’m not sure, seems not admin… I just double clicked the exe icon, and no error or any warning appears until installation finishes.


#6

You won’t see warnings during installation, but unless you run the installer as administrator (using run-as, not simply while logged on as an administrator) there are likely to be downstream problems due to permissions on files and folders.


#7

It is very unusual for an application to cause a windows blue screen unless it is using some portions of a .dll ( probably graphics driver not used before).
When you down load Su save to a file location and then before running exe check file properties you may see at the bottom what is called unblock, you should do that especially if the file is a zip file since that action will unblock all the files in it. Then you should do as suggested above. Did you get a crash dump form windows it may give you some idea what is causing the problem but usually one needs a symbol file etc from MS to actually read it.
If you still have the same problem suggest you check for graphics or other windows updates.
Usually when you have make that means you had 30 day free trial for SU pro did you have any problems with it during that period or??


#8

blue screens are typically triggered by defective hardware or faulty hardware drivers only… not by applications.

Try starting W10 in safe mode and check for new installations of drivers.


#9

that is true but look at some history of MS crash dump analysis. That flat statement does not work, I for one had that very case occur several years ago. I had graphics drivers very old and new app I loaded called and part of the dll not used before that caused a blue screen.
Before spending lots of time on drivers I would probably reload the app. As you well know sending 1,0’s across the net is not error free , packets have errors, the MD5 cannot id all errors as is not designed for burst errors. That is reason the TVs now use a interleaving depth =>notice you no longer have shadows for that very reason.


#10

that statement does exactly work.

probably caused by the flaky graphics driver.

Corrupted downloads are very seldom at least today and regularly covered by the error check every common setup application is doing before installing anything.


#11

And so what? I have designed secure comm. systems for inter planetary distance and near earth. Various codes used have different capability including the crc used for tcp/ip packets and the ones used for hash checking. Just recently a post noted sha -1 would no longer be used for code signing reason is it was subject to spoofing. That is main driver for all the attention to ’ LTE’ networks. Codes are used for error detection and error correction, the more you detect and correct the more redundant 1’s and zero,s are required in the data block and less real data is set, to avoid that confusion we many times use symbols for the over head vs bits for real data. The bottom line it is possible errors occur in symbol/data blocks that are not detected nor corrected and you cannot assume just because checks are made it is guaranteed good.
Any time I down load program and it does not work I reload.


#12

[quote=“mac7595, post:11, topic:32732, full:true”]
irrelevant stuff snipped[/quote]

at least 99,99% problems launching SU are not related to errors of a finished download, therefore claiming download errors doesn’t help the vast majority of users with problems of this type.

the problem is not the setup/installation of SU but launching SU. The most likely reason in connection with the AMD FirePro used is the known flaky 64-bit support of the OpenGL stack of the used driver. For fixing this using the 32-bit version of SU might help. As a last resort the accelerated display output of the GPU (powered by OGL) can be disabled in SU under “Win:Window/Mac:SketchUp > Preferences > OpenGL > Use Hardware Acceleration”.