Sketchup Make 2017 ridiculously slow

sketchup
advice
bug
modeling

#1

Hi,

I just recently downloaded 2017 and I’m finding it ridiculously slow. I’m currently designing (for fun) a house, and what took me 2 seconds (say for example, push/pull, move, &c.) is literally taking 5 minutes and says that sketchup is not responding between each move. I’ve tried removing textures, removing colours, nothing appears to be working. And since I can’t open the file in older versions, I’m stuck with 2017. It’s not a huge file, and I’ve had tremendously bigger files open in 2016 with minimal to no slow down, so I doubt it’s the file size…

Here’s what it’s running on:
Windows 10 Home (64-bit)
Processor: AMD A6-6310 APU with AMD Radeon R4 Graphics
8GB RAM

Also, unrelated… Does anyone know where the materials folder is for 2017? I looked through the folders and can’t for the life of me find it. I wanted to add my own *.skm files.

Thanks in advance!


#2

The default materials are stored in

C:\ProgramData\SketchUp\SketchUp 2017\SketchUp\Materials

The programdata folder is invisible by default so you might have to make Windows Explorer show hidden files and folders firtst, or, to access it, you can type %programdata% in the Start menu Search box - this opens it in Explorer.

Anssi


#3

There’s a directory in AppData now too C:\Users\username\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Materials. Also you can set preferred Materials location through Window > Preferences > Files. For custom material libraries, you can set any location you want for your custom stuff and direct SU to add it to your favorites through the details menu in the Materials browser.

Your not stuck with SU17. Down save the file to an earlier version if desired.

Regarding experienced slowness, try updating your graphics driver. Share a ‘slow’ file here for others to test.