Materials palette/paint tool freezing in 2017

bug

#1

Our firm is using SketchUp 2017 with macOS Sierra and we are finding the materials palette and paint bucket tool to be extremely slow. Just selecting the tool, selecting a material, or attempting to edit a material results in freezing for 30 seconds to a minute. We use the CleanUp tool and model file sizes are no larger than we have worked with in the past (~140MB). Taking the models back into SketchUp 2016 has a less severe issue but still atypical. Any ideas would be appreciated!


#2

I’m on Sierra but not doing large models daily. When you open the color panel, select the brick, and select the pulldown “Colors in Model”, how many materials do you have in your models. And how big are the materials? Are they custom? Do you have lots of swatches saved? (bottom of color panel)


#3

Thanks for your response. We did have quite a few materials, so that was a good tip to try. I deleted several so that we are down to 25 materials in our current model. The file size is now 66MB, which is a big improvement. Strangely, the materials palette is still very slow to work with. I tried cleaning the model again and restarting my computer but that aspect has not changed much.


#4

Does it make a difference if material thumbnails are displayed, or the inspector is set to just list as text materials names ?
(On PC it is called “List View”.)


#5

Have you added/saved any custom materials to the material libraries?


#6

Thanks for this idea, Dan. I have the “list view” option with Styles and Scenes but not with the Materials Palette. I wonder if that is a PC only option. I continued to delete more and more materials and pasted the model into a new file again, which seems to be helping.

Update: eneroth3/Barry - even after deleting all inessential materials, and getting the file all the way down to 36MB the file was still very slow – I finally realized that one of the remaining ~20 materials (a custom one we had made and imported) was about 10MB. It seems that this rendered the materials palette unusable despite clearing 100MB of other materials/linework through the CleanUp3 process.

After downsizing the large material file and reimporting, the file is working great. Thanks very much for all of your help!!!


#7

Yes, that option does not exist on Mac SketchUp.

Glad you found the culprit! Because the Mac SU Materials window does not have the list view it always displays thumbnails. A very large image can bring the Materials window to a crawl.


#8

@Barry, SketchUp really needs a downsized thumbnail caching folder / feature. Simple things like this should not be dogging down the inspector panels. This is an old issue, I remember some cycles ago there was work to speed up thumbnailing. But it never worked well, so I always run with all inspectors in “text name listing” style and only temporarily switch to thumbnail images when I absolutely need them. (And switch back A.S.A.P.)


#9

This topic was automatically closed after 91 days. New replies are no longer allowed.