Sketchup Make 2017 Mac OS Big Sur Dimension tool text up side down?

Upgraded to Big Sur, created a new file, and when i used the Dimension tool to show the dimensions of a line the text is upside down. Rotating does not fix. Flipping does not fix. This also affects existing files where there is dimension text.

Bug? Some setting somewhere? Any idea on how to fix?

Interesting. I’d guess it’s a bug because SketchUp 2017 wouldn’t be compatible with Big Sur.

As to fixing it, either upgrade to SU2020 or drop back to your previous operating system.

Maybe @greenteagod knows, it is said theyre connected.

For me this is only true on a M1 chip Mac. Are you using an Apple Silicon developer machine, like I am, or did you get your preorder very quickly?

On my MacBook Pro the dimensions are correct.

1 Like

Thanks for pointing to the other thread. I promise I searched but didn’t find anything. It’s helpful to know it’s not just me :slight_smile:

Still waiting for my M1 chip Air

I’m currently using:
MacBook Air (13-inch, Early 2015)
Processor: 2.2 GHz Dual-Core Intel Core i7
Graphics: Intel HD Graphics 6000 1536 MB

For that setup the bug is happening in 2017, 2018, 2019. It is not happening in 2020 or online.
Doubtful we’ll see a fix in pre 2020 versions so since my models are pretty simple I’ll probably just make the move to online.


Trimble almost never issues patches for old versions.

je rencontre le même problème, quel dommage …

From Google translate.

“I have the same problem, what a shame …”

Yes. It isn’t the first time Apple has released a new operating system that has broken applications. Hopefully they will fix it.

oui …

Unfortunately not, if any investigation is being done into it it’s beyond what I have the capability to view.

1 Like

Exactly the same here.
It happens on both my iMac and Macbook Pro after upgrading to Big Sur…

Super frustrating right now.

I am not sure if the SketchUp team should do the fix or it is something wrong with Big Sur.

This could be the Aussie version?

Nop, I guess it happens on all Big Sur.
All texts turn upside down on all my old Macs installed Big Sur.
I am using SketchUp 2019.

Hello folks, I signed up here just to add this comment. I have a 2019 MacBook Pro 16". Sketchup Make 2017 has been running fine on it. I upgraded to Big Sur a few days ago and opened Sketchup for the first time just a few minutes ago and had the upside-down dimensions. I’m using metric settings.

I of course tried rotating the objects but that didn’t work. Then I started searching online and found this. Very strangely, after a few minutes when I switched back to Sketchup, my dimensions were OK. There was no visible changeover so I can’t say when it happened - behind the scenes while searching or when I switched back.

I just clicked Undo to undo the rotation and the measurements are still displaying correctly. I have also just saved the file, closed it and closed Sketchup, then reopened, and everything looks normal.

I know this isn’t much help but it might be useful to know that it can come right.

It is interesting though. I had seen the upside down dimensions in an earlier builder of Big Sur (on an Apple Silicon Mac mini), but not at all on my MacBook Pro after I upgraded to Big Sur.

@mchandler can you check on the M1 machine?

I’m not seeing anything strange with SU2021 on the M1 machine.

Try the same test with Chris Dizon in the scene, this is a 2017 specific issue.

Here’s what I see with SU2017:

Dimensions are now showing correctly for me as well in SU2017.

M1 Mac Air
Big Sur 11.1 Beta (20C5048k)
Sketch Up Make 2017 Version 17.3.116

Thanks for checking. I still get the upside down text with the A12Z Mac mini, but no problems on my MacBook Pro.