SketchUp Make 2017 generates artifacts (unwanted lines) while saving

render

#1

I’m having a problem with SketchUp Make 2017 on Mac OS X 11.6.:

At a certain point (complexity/size?) of my model, SU draws unwanted lines into the model while saving. These artifacts get successfully saved within the file, and are even visible when reopening the file. To get rid of the artifacts, I have to undo some steps, until before the artifact.
SU reproduces exactly the same artifacts every time I try to save the model again. (I could make a screencast for visualizing the problem)

If this is a known problem, I do appreciate any help or hint to the topic already in discussion.

Best regards, Matteo


#2

Can you post a model that displays this problem? Does it happen with all your models?

Are you using plugins? If the lines you mention are actual geometry (you can select and manipulate them), then the only thing that comes to my mind is a misbehaving plugin.

If they are just display artifacts, it is possible that SketchUp 2017 is not totally compatible with your version of MacOS. In the last couple of years Apple has released new versions of their OS, and SketchUp 2018 and its latest maintenance update have tried to keep up,


#3

If you can share a model that exhibits this problem or at minimum a video or some screenshots, that would greatly help us understand. I’ve not seen this on my Mac, so I’m not at all sure what may be happening.


#4

As @slbaumgartner says we need to see the model. But from your limited description it sounds like you have moved one point out of alignment, which is causing everything to fracture.


#5

It‘s the first time I got. this problem.

I also only use a plugin to save to an STL file.

I‘m don‘t have the latest version of Mac OS because it wouldn‘t run any more on my mac.

I will send the file and a video tomorrow because I Need to go to the computer to do it

Thank‘s Matteo


#6

The strange thing is, that everything looks normal until you save the file, then the artifacts get created.


#7

So, you can download the video and the files with this link: https://www.dropbox.com/sh/hxi7zm18m6eqnnv/AADf8nEWUdmJ6bRGKB1tg9-Ra?dl=0

I hope this will help you.

Best regards, Matteo


#8

The point at which you want to intersect the tail with the fuselage just happens to be too close to a junction in the geometry, move it slightly and it works, as you see in the gif.

A couple of side notes. You need to purge your model, I removed 7mb of unused stuff from it. Window/Model Info/Statistics Purge unused.
You should look at using layers for visibility purposes rather than hiding everything. It gets very confusing and difficult to work with when there are multiple hidden objects in different contexts. As seen in the gif when I turn on hidden geometry, you get these hidden meshes in the way.

Move%20geom


#9

Thank you really much, this solved my problem.
But there is still one question: Why does this only happen at saving, and not before?

However, I think I can continue working on this project so thank’s for your help.

Best regards, Matteo


#10

I imagine it is because the model gets checked for errors when you save it and it attempts to fix them.
You can turn this option off but it may not help.
Check%20Model


#11

Yes, that makes sense.
Thank you very much again, Matteo