Sketchup locks and bongs at me in W10

I suspect I have installed an extension which is causing the problem, but I’m not sure. But Sketchup locks as soon as I open it, and just chimes whenever I try to do anything. I can’t access any menus or tools, or even quit the application other than force quit from task manager. I’ve tried deleting the extensions folder as was suggested on one thread, but didn’t make any difference. Its hard to diagnose what’s going on without any access. Any suggestions?

Probably a window opening off screen. Potentially due to an incorrect installation of SketchUp. Try repairing the installation of SketchUp. Go to the downloaded installer file, right click on it, choose Run as administrator. Then if prompted, choose the Repair option.

I ran as admin, and chose repair but its still doing exactly the same. I think you’re right about window off screen somewhere, something flashes up just before it opens in full screen, but I can’t even resize sketchup to see if there is a popup open somewhere.

When you get into the state where you are being bonged at, do this:

Alt-spacebar, then release both keys.
Tap the M key (for Move, tap a different key for other languages).
Tap any arrow key.
Move the cursor.

The lost window should be attached to the cursor.


Thanks. I deleted sketchup and reinstalled - its still locked up and bonging on restart. I’ve tried the keystrokes above as well and no window appears. I’m very confused as to what state its actuallly in. Looks perfectly normal, with my model displayed, just won’t do anything.

As has been noted, these symptoms are usually because SketchUp is waiting for input on a modal dialog that you can’t see. It won’t respond to anything else until you get that window to close.

Have you ever run with an external monitor attached and then removed it or changed how it connects? If so, try reattaching it and see if the window is somewhere on that display.

No, I’ve never run an additional monitor. I did change the monitor settings this am - but only to reduce the brightness a bit. And I’ve completely reinstalled sketchup since then. Is there any way to force output to the main monitor or equivalent of a terminal window??

My steps will retrieve the window. You could also try Windows key-up arrow. That will make the window as tall as your monitor, and hopefully will center it as well.

Thanks Colin. Tried both, and still the same. I don’t understand why a completely clean install didn’t fix it.

Try changing the default browser in Windows

I fixed this in the end by removing an extension and libraries. I hadn’t realised there was more than one extensions folder. Thanks for the help everyone, all back running now.