SketchUp lag

I’ve mostly been using SketchUp Make 2016 since it came out, but I recently switched to 2017 so I could download certain models from the Warehouse. However, it seems 2017 is very buggy, or lagging. For example, I’ll open a group/component to edit and immediately switch to the Line tool (or any other tool for that matter) but it takes 2 seconds before the switch registers. Or if I select a face/line/group and use Move to move it, the command will lag 2 seconds from the time I click on the item to the time it actually moves to where my cursor is. It basically lags on every input click or keystroke, and when I switch from one tool to another.

At first I thought it was my dated CPU that couldn’t keep up with the workload, but I just built a brand new pc and it’s still the same. This happens with every model, even ones I ported over from 2016, which I never had issues with in SketchUp 2016, no matter how complex the model got. This is really messing with my workflow, does anyone know why it would be so laggy?

Thanks.

doesn’t help. there is no change

I read a lot of that other thread, and I think the disable use fast feedback was for the benefit of users with integrated Intel GPUs. If your PC has a discreet GPU you could try making sure that is the one being used, and then also make sure use fast feedback is checked.

… also make sure your Nvidia driver is up to date and that you are following the performance suggestions.

You might also try disabling Autosave in Preferences (just to see if there is any change.)

There is also the possibility that either a SketchUp extension or an anti-virus program is interfering.

SU recognizes the discrete gpu and it is listed in the gpu details under OpenGL. My cpu doesn’t have an integrated graphics chipset.

Nvidia drivers are always up to date, but it hasn’t made any difference any time I updated to a new driver.

It seems to be a problem specifically with SU2017, as SU2016 runs smooth as butter. I’ve opened the same model in SU2016 and it will run without issues. OpenGL settings are the same in both programs: True Color with 4xAA and fast feedback on. Yet when I open a model in SU2017, it’ll run ok for some time, then progressively get more and more laggy. Also when I first open SU2017 and the workspace loads up, it takes 20 or so seconds before I can click any buttons in the program. If I try clicking anything before than, it goes into Not Responding mode.