Select Tool lag issue on Windows 10

Hi, I’ve been dealing with this lag off and on for sometime. It seems like the options are; keep uninstalling Windows 10 security updates (which seems inefficient), or use Sketch up on line version, or purchase the 2018Pro version?

Or, since the main cause is related to some Intel graphics drivers not being suitable for applications that require good OpenGL support, get a graphics card that can handle it and don’t let Windows reset the Intel graphics as the default.

I’ve been using Windows 10 for several years on a computer with an Nvidia graphics card. I’ve never had any issues with this slow selection thing but I keep tight control over updates and make sure the Nvidia card remains the default for SketchUp and LayOut.

It’s worked on this computer since Sketch up version 14, but started to get weird around version 16. I would like to think I live in a perfect world, where my computer, the program and all components required to run the program all align and work with each other. If that’s not the case then I have to rely on the Sketch up diagnostic tool to tell me if there is anything required by Sketch up that I don’t have. The tool says I’m good to go with everything.
Pretty sure it’s not a graphics card issue. Also from my intermittent research it’s not the same update, and it seems to vary. But is kind of my point. I’m glad your version runs so smoothly Dave.

Was having issue with Surface Pro (2017) running intel HD 620 & Windows 10. I applied the script & now it works! The lag is now gone. Very relieved because I was planning to return the surface pro to Microsoft & get something else. Thanks

2 Likes

the graphics card driver and the provided OpenGL capabilities is definitely involved in causing the mentioned issue.

Integrated gaphics solutions (= cheap & lame) were never meant to use with demanding 3D modelers but good for office stuff or internet or videos even if consumers did not understand the difference.

If you are seeing this issue on SketchUp 2017, please try disabling Fast Feedback to see if it helps (Preferences > OpenGL > Disable Fast Feedback). Let me know if that helps.

This seems to have solved my select tool problem as well.

How do I find out about these patches/scripts ? I have a maintenance account. Is there a way I can be notified or do I have to stumble around and search on this forum ?

if being affected by an issue contacting the tech. support would be a common behaviour.

On my phone so can’t confirm, but wasn’t the Disable fast feedback removed from 2017.

nope, the “Hardware Acceleration” (aka OpenGL via the CPU instead of the GPU).

1 Like

That’s the one. Knew I needed to check. Thanks.

This didn’t fix my problem with SU Make 2017. What else can I do?

The script doesn’t work for SketchUp 2017, you can upgrade to SketchUp Pro 2018 and run this script or you can try disabling Fast Feedback in the OpenGL settings of the Preferences window.

Disabled the fast feedback and that didn’t work. Can I borrow $600 from you to upgrade to Pro? Just telling me to upgrade seems insensitive to me especially since I teach others how to use SketchUp Make.

Thanks,

Jeff

1 Like

Unfortunately, because this is due to a recent Windows update, we don’t have a lot of options. The other options would be to update your video card (this only seems to effect integrated Intel video cards) or uninstall the Windows update that is causing the issue. Please see this post for more details about this issue with SketchUp 2017: Selection Tool process is slow, unbearably slow

Jeff, I think you misunderstood Ty. He was indicating that the script only works with SketchUp 2018.

If you’ve installed SketchUp correctly, the things to do are:

  1. Try updating the Intel graphics drivers.

If that doesn’t help…

  1. Roll back the driver to an earlier version when it did work.

  2. Get a graphics card that is reliable and up to the job. Intel Graphics HD GPUs are well-known to be lacking in proper OpenGL support. Of course upgrading to a good card (Nvidia) may not be possible without replacing the entire computer. Such is the case with most notebook computers.

  3. Go back to an older version of SketchUp, such as 2016, that allows you to turn off Hardware Acceleration and dump rendering duties back on the CPU.

So I tried selecting and deselecting things in preferences, and in my
graphics card settings as well. I finally just re installed 2017 Sketchup
and chose the “repair files”. It worked, it was like an early early
Christmas present, so sweet. THEN I woke up this am,opened Sketchup, the
lag has returned! I have no idea what the problem is. I haven’t had any
updates in the past 3 days. Nothing has been altered on my computer. So
what do I have to do? Buy a new computer? What do I buy? What are the
requirements? I mean according to Sketchup diagnostic tool I meet all
requirements. It is so frustrating, and frankly keeping me from purchasing
the PRO version.

I am on Windows 10 with an Nvidia and have never had to rollback updates. I had an issue some 6 months ago. I updated my Nvidia driver and the problem went away. However it has now returned and affects SU 2017 and SU 2018.

I have always use “Run as Administrator” when installing all Windows applications. I have a friend who has an AMD Radeon graphics card. He is running Windows 10. He is experiencing the exact same problem.

I can duplicate the problem with a very small script. The script is run from the Extension menu under GKWare Test. It simply creates 100 square components. This is always fast. Then I create another component manually and watch the blue circle of death spin for around 20 seconds or so. The component is finally created.

What is very interesting is after the initial long wait I can create another component manually without any noticeable slowdown.

I have looked for KB4013429 and KB4015438 but neither appear in the uninstall drivers list.

gkware_test_v1.0.1.rbz (2.0 KB)

Since I don’t do much manually creation of components this doesn’t affect my everday programming. However - I would still like to resolve it.

Does anyone have a complete list of bad windows driver updates?

Ty_s,

what is the correct way to run the script fix once it is downloaded. I just bought SketchUp Pro 2018, downloaded the script, tried to run it and there is no change to the select tool lag in SketchUp Pro 2018.

Thanks,

Jeff