Sketchup is not allowing me to draw diagonal lines

This is new. I have modeled tremendously complex projects with sketchup, I’m not a beginner. But suddenly, it won’t complete diagonal lines. I can draw a square, and I can’t draw a line from corner to corner. Same with making a simple right triangle. I’m seeing the snap indications, but when I’m done, there is no line. I just installed sketchup 2016, thinking that would help. But maybe it is still using some of the (presumably) corrupted setup files? I’m guessing I need to do a full reinstall.

Anyone encountered this? Is there a folder I need to trash? Can I save my keycommands through the process?

Could you upload a SketchUp file (.skp) after you’ve tried to draw the diagonal line? Let us take a look at the file and see what’s happening.

As your situation would appear to be something of an unusual occurrence perhaps you could see yourself clear to add some sort of graphic or filial information if it’s not too much trouble.

Have you updated your Graphics Card Drivers recently ?
SketchUp v2016 in Win 10 needs the latest drivers…
This might be the reason you can’t draw some lines…

What are your Preferences > OpenGL settings ?

Hah, TIG, that did it!

Maybe the first time I’ve experienced out-of-date video driver problems… I thought win10 would ship with usable drivers for my computer, which is a 2014 model. And the old drivers were dated november 2015–seemed pretty recent to me!!

Okay, guess I’m not out of the woods yet. Here are some hopefully helpful attachments.

Oh. Looks like there is no way to attach a file??

Yes there is. Click on the Upload button, 7th from the left in the row of buttons above the text window in a reply.

Okay, cool, thanks. Did a search and got out of date info, I guess.

I’m trying to draw a circle as shown, and the second click seems to be interpreted as the first click, so it doesn’t draw. Same problem I was having with lines. Also, I tried to draw the rectangle on the left where it is shown, but it didn’t work. But I was able to draw it elsewhere, and move it.

Seems to be an issue with co-incident points?

Here are also attachments for my openGL settings. Windows says my graphics drivers are now up to date.


Aak, new users can only put one image in a post!

Please wait 11 seconds before replying…

okay, and here is the skp file.LineProblem.skp (151.8 KB)

okay, just tried the exact same thing again and it worked this time ???

Well, couldn’t get that to happen twice. In fact I cannot draw a circle that has any relationship to the existing drawing. I can only draw a circle in empty space.

Evidently you weren’t holding your mouth right before. :slightly_smiling:

I tried it in your model and had no trouble. Keep your eyes peel for it again.

yeah, I can’t imagine it’s the model, as I’ve tried with 2 fresh models and the second thing I tried failed each time.

I have to imagine it’s a corrupt source file of some sort. But it survived from v2015 to 2016.

I’ll try a completely fresh install when I get another free moment.