Sketchup Glitch

Need some help please. My sketchup view is glitching…creating an echo image when rotated or panned. The echo’s arent there, so the model is still intact, but awfully annoying. Any ideas?
Thanks

Looks like a graphics issue. What is the graphics card in your computer? Make sure its drivers are up to date (check with the graphics card manufacturer. Do not trust Windows to tell you.) Under Preferences>OpenGL you might try changing the setting for Fast Feedback.

Also make sure your model is not positioned at a huge distance from the origin.

Changed the settings for fast feedback and it worked…no more echos. Thanks!!!

It would be useful to identify your graphics card and update its drivers to make sure.

I have seen some of this behavior when gaming, in the past.

Dave pointed you to the right place to fix this. For your interest, this problem was introduced with 2019.2 I think. Before that version we would get a lot of support cases where the scene was blank, not even any axes lines. It was almost always on a Surface Pro that was using an underpowered integrated Intel GPU. The solution put into 2019.2 was to show a warning message if you were currently using Intel, and you had an alternate GPU you should be using. Also, the Use fast feedback option defaulted to being unchecked if you did continue to use the Intel GPU.

That completely stopped the support cases from Surface Pro users, but unfortunately, people with more capable Intel GPUs then suffered these line artifacts. The solution is to turn Use fast feedback on again.