Sketchup Geo-Location Import Errors

Good Morning, I have imported geo-location hi-resolution maps before and I have not gotten this error.

“There was a problem importing your purchase. Would you like to import your purchase now? Make sure you have the correct file open. If you’re not set up to import your purchase, click “I’m not ready”. You can use Add Location but you will not be able to purchase more data. To see this message again, restart the add location service.”

It gives me 2 options, “I’m not ready” and “Import Now.”

If I select “I’m not ready” it allows me to import a low res map, if I select “Import now” it give me this error:
“Payload Error! Please close the Add Location window and re-open it. If the problem persists contact customer support.”

I have cleared my internet cache and logged out multiple times.

I have searched the forums, the internet, and called support with no success.

Any help resolving this issue would be greatly appreciated.

Hello,

Like @JrarickRJB, I have also imported geo-locations before in the past and have not had any issues until recently.

My problem is similar but not identical to the above referenced issue but instead of the “Payload Error!”, SketchUp only allows me to import the same geo-location from when the issue first arose. There must have been an issue on SketchUp’s end when I went to import the geo-location because now it thinks that I haven’t imported the last imagery and it wants me to import it. Even if I do import it, it doesn’t clear the “memory” of having imported it and thus I am in an endless loop of importing the same imagery.

After I close and reopen SketchUp (logout and login, restart computer, etc.), I get the same message about “There was a problem importing your purchase…” and when I click “Import Now”, it imports the same geo-location and I am not given the option to purchase tiles for a new location. If I click “I’m not ready”, it holds onto the imagery and doesn’t let me purchase anything new.

Essentially, I cannot use the geo-location feature anymore. Any help would be appreciated.

Thanks in advanced.

1 Like

We haven’t figured this out yet, but your current endless loop can be fixed. Contact support with enough information for them to find your order (date, amount, email address you used) and then can unblock add location for your account. If they did that today, add location would work for you tomorrow.

Unfortunately, if/when you buy more tiles, after tomorrow, it would be in a new loop. I do see the issue on my computers, so if they do fix the issue I will know if it is fixed.

Use this page to send in your information:

https://help.sketchup.com/en/contact-support/billing-question/form

If have already done that, support will be in the process of unblocking you and other people who have reported the same problem.

The underlying problem has been fixed, new add location purchases should not get stuck in a loop. Someone who is currently stuck in a loop may seem to still be stuck. Signing out and in again should clear that up.

I am still stuck in a loop…

What version of SketchUp are you using. Complete your profile.

1 Like

2021 until today, when I was able to completely sign out of both computers I use for Sketchup. Then was prompted to upgrade to 2022, which I also tried. uninstalled both 21 and 22, then reinstalled…cleared caches etc. have not tried digging into reg files yet. Seems to have coincided with trying the Placemaker plugin…?

The loop problem should have cleared itself after you had signed back in again. May need to get the current order cleared, and see if you can then make new purchases without getting stuck in a loop again.

If you were in contact with support about the loop problem, reply to the last message from us to say that you are still stuck.

I am suspicious that when I asked to change my account owner email address they made changes to my account that caused the error looping.