SketchUP freezes when trying to open Preferences window

Hello, I tried to find a solution to my problem but unfortunately it failed.
I have a problem with sketchup 2020. In general, the program works very slowly (jams when rotating larger models, entering groups, etc. - not to mention the shadows on) - although I think it should work OK on my hardware configuration - full specification below .
But the biggest problem comes when try to open the Preferences window - the program completely freezes and refuses to cooperate. The only option is to turn it off from the task manager. I tried to reinstall but it didn’t work.

The following results are displayed when using SketchUp 2020 Checkup:

Error: Something went wrong while retrieving the system information from your computer. This may cause tests regarding System RAM, Windows version and / or graphics card memory to fail.
Error: Graphics card information is missing.
Success: System RAM requirement has been met!
Success: Operating system version requirement has been met!
Success: Graphics card OpenGL requirement has been met!
Success: Graphics card Hardware Acceleration requirement has been met!

My hardware spec:
Windows 10 pro x64
NVIDIA Quadro M4000 8GB
Intel Xeon E5-1650 v3 3.50ghz
32 GB RAM (server)
samsung SSD SM841N 2.5 7mm drive

I am asking for help, if someone only has an idea, have to work and feed the family :slight_smile:
Best wishes

When you think it is locked up, does pressing the Esc key get you going again? If it does, it’s possible the Preferences window is offscreen somewhere.

After choosing Window/Preferences, type Alt-spacebar, then M, then any arrow key. Move your cursor, is the preferences window attached?

If you get into Preferences, check the OpenGL settings, to see if Use fast feedback is selected. That may help performance.

Thank you, indeed, I recently installed a second monitor and the preferences window landed outside of the observable area. Again - thank you :slight_smile: