Sketchup freezes when I select view in menubar then toolbar

Have an issue with sketchbook freezing each time i click toolbar option under view. I have just reinstalled Sketchbook pro 2021 on my windows 10 laptop and the issue remains. Also when i am now using drawing tools lines are not complete or partially visible. I have downloaded check up and my system is fine for sketchup. I need advice as the app just hangs.

Are you talking about SketchUp or Sketchbook?

Very likely the Toolbars panel is opening off screen. Did you have a second display connected? Try going to Window>Preferences>Workspace and clicking Reset Workspace.

Show a screen shot or what you are seeing. It maybe that you need to update your graphics drivers. CheckUp won’t necessarily tell you that.

Or maybe you have the camera set to Parallel Projection and it’s so close you are getting clipping. Hard to tell from a few words.

Sketchup :wink: slip of the keyboard! I checked if it were off screen - i can open the preference box under windows and its within the main screen.
My graphics drivers are up to date (Intel IRIS R) and screens on extend. Re screenshots the first is on opening, the second is in selecting toolbar and the third when the menus are greyed out and i cant draw,

If reset workspace doesn’t get the toolbars window back, do these steps at the time that the menus are grayed out:

Alt-spacebar, release both keys.
Tap M, then any of the arrow keys.
Move the cursor, the window should be attached.

Click when you want to drop the window off somewhere.

1 Like

Thanks Colin - tried what you suggested but no joy, thanks for help though. I ended up restarting and then working on laptop screen rather than monitor. Works fine on the smaller screen but really wanted to work on a high def monitor. Do you know if there are issues with SU working on extended displays. I have it connected through a HDMI via a multi port connecter.

I have met with problems when using these laptop docks. Some older ones won’t even let you open SketchUp on an external monitor as they don’t support OpenGL. Things to check:

  • firmware in both your computer and the dock
  • your Thunderbolt software/driver, if you connect the computer to the dock via USB-C
  • possibly your network driver as well
  • cable type to use connecting the monitor to the dock. Some 4K monitors I have met didn’t support full resolution through HDMI, only through DisplayPort or USB-C…go figure.

Was your laptop lid open or closed when you had the dialog missing? My work HP laptop and dock move (now that I got the things listed above sorted out) the “main display” to the external monitor quite reliably when I close the laptop lid.

Laptop was open - I was watching a SU tutorial on my HP laptop (Spectre i7 10th Gen so processing ok and lots of available memory) at the same time i had SU on my monitor - btw monitor not 4k its QHD.

Can you look at the menu in the upper left of any window, and confirm whether Move is “move”, or some other word?

image

Did you need this with the display on the monitor or laptop?
Attached is on Laptop - Move is there but greyed out.

It’s gray because that window is maximized.

What I was checking is what the keyboard shortcut was for the menu items. For some reason you have Windows set up to not use keyboard shortcuts. If you look at my screenshot there is R, M, S, n, x, and C as shortcuts. You don’t have those, and I haven’t seen that before.

If you can figure out why those shortcuts are missing, and get the M for Move shortcut to appear, the steps I gave earlier on to retrieve the lost window will then work.

Colin apologies for delay and a BIG thankyou as your suggestion did work and i have managed to get the toolbar menu to appear. I did as you suggested alt+spacebar then M and arrow and the menu appears on my mouse curser within my laptop screen and can only be seen if all other windows are reduced. I then move the toolbar back to the sketchup screen and its fine until i want to reopen the toolbar option again and then i need to repeat the process. How do i get the toolbar menu to open in the screen where i have sketch up?

When you have it showing, try doing a reset workspace, see if that forces it into the usual location. Go to Preferences in the Window menu, choose Workspace, then click the Reset Workspace button.

No joy - the strange thing was that preferences actually opened initially in the same hidden way then after moving it stayed where i left it but view toolbars is hidden every time

Just Checking, Make sure you have the menu in the right place on the last instance of sketchup that you close. All setting like that will remember the last one, so if you happen to have two open and change one but close the other last it will remember the wrong one.

Re did with toolbar options last to close and also as the only one to be open but issue still persists

Ok, was worth a try.

Thanks Box, im beginning to think its something to do with the QHD nature of the screen i.e.
2560 × 1440 pixels in a 16:9 aspect ratio