Sketchup drawing code is incorrect and needs an update

Textures that aren’t being used shouldn’t be influencing draw times. Typically, a culling volume is created, rays are fired through the volume and any faces that are deemed visible are quarried for their properties. If those properties dictate that there is a texture map, the data of the texture is queried.

In other words, if a texture is not visible, it shouldn’t even be considered. This is especially true when the texture isn’t even used in the scene.

This is clearly not what Sketchup is doing. This became apparent to me when we started working on a site plan that is MUCH larger than we typically work with. This required 30+ MB of satellite images be imported. The performance was poor, so once the “location snapshot” and “location terrain” objects were no longer needed, they were deleted from the scene. Performance didn’t improve. We were confused, because we were left basically with a hand full of boxes; probably less complexity than the Heather model in the default scene.

Well, all we had to do was purge those materials with the satellite textures out of the scene.

There’s no reason to index items that aren’t visible in the viewport, much less if the items aren’t even in the sketchup model.

You must know that SketchUp resizes all images and textures to fit the maximum size defined by the system. The default is 1024 x 1024 pixels. If you check the “Use maximum texture size” box in Window>Preferences>Graphics the size depends on your graphics card driver, with maximum 4096 x 4096 px. This doesn’t seem to affect Match Photo images. The extension Large Image Splitter lets you keep the original resolution by splitting the image into chunks that fit the texture size limitation.

2 Likes

Texture size should not matter in the issue I’m talking about. Culling was invented in the 1960s. No joke. If the camera doesn’t see a surface, it shouldn’t index the image. Beyond this, lets look at the situation I’m actually considering. If the image isn’t even used on any geometry, it shouldn’t be considered at all. It shouldn’t be loaded into the graphics card, that table of the data structure that Sketchup uses, should never be indexed at all.

There are zero reasons that the interface should be a sluggish as it is with even 6 TB of data as long as it that data isn’t being addressed. Test it yourself. You can have a single box with no textures assigned and load in a 2 square miles of satellite data. Sluggish, right? Now delete all of the geometry that came in with those satellite images. Any graphics system developed in the last 50 years would not care what used to be renderable. But as you can demonstrate for yourself, that is not the case with Sketchup. It’s still sluggish. With only a cube with the default material applied.

time to move on to a better software I guess.

I was just pointing out that importing very large raster images is pointless and only bloats file size.

Are you a member of the SketchUp development team? You seem to be very certain about what the application is doing “under the hood”. We mere mortals don’t have such knowledge.

1 Like

Could you please, prepare or send your sluggish model file mailto:developer-support@sketchup.com
This is the fastest way to get the issue in front of the SketchUp graphics team.
Also provide any instructions.

1 Like