Sketchup 2024 Adding textures as solid colors instead of textures

Hello everyone, so it’s the 2nd day I am trying to solve this issue, I download an image that I want to use as a texture (floor), and as always I would add it to my textures and it would work, but now it is just filling the face with a solid color instead of texture, I have googled about this, checked that I have the right view "shaded with textures"and my project is also not big, on sketchup itself it measures at 7000x4200 millimeters, and yet it is not working. Any help greatly appreciated!

How did you add the image to textures?

What is the actual dimension of the texture in the material pallet?

Do you have ‘use large textures’ turned on (somewhere in settings).

Are you applying the texture to a face or a group?

If properly applied to a face - select it then right click and make sure it is not ‘projected’.

Also, for better help post the model here. If it is too large use Dropbox and share the link.

I usually add it through left-clicking the paint bucket tool which opens materials, there I choose new texture, and select an image located on my hard drive. The actual dimensions of the texture in the material pallet are 1000x1000 millimeters, I don’t play with these settings and keep them default. I am applying the texture to face.
Trying to find now where to check the “use large textures”
For some reason I am not seeing the option to make it not projected when I select the face to which I applied the texture and right click on it.

Walls1.skp (680.2 KB)

You should be using groups and components to model efficiently.
Learn more here:

How are you selecting the material to apply? Press B (shortcut for paint bucket) then click the color and click the face.

With all those shades of brown in your materials pallet I am guessing you were using the little eye dropper in the lower left of the materials pallet? That is for sampling a color on screen… not for choosing the texture.

The preferences are here:

Well that’s the way I do, I understand the dropper tool is for sampling, I used it a couple of times to try and see if it is seeing it as a color or texture, The different shades are from different types of flooring I tried to add, “use maximum texture size” was already checked. But I always fill the face with paint bucket tool not trying to do it with the dropper tool. The interesting thing is if I choose default textures they show up fine, maybe the fault is how I save the image? I save it through the browser and it saves the image in *.avif format, which I just rename to *.jpeg?

Update: the problem was due to chrome saving the image in the wrong format and me re-naming it. Just used another browser and now it is fine. Thank you for help and tips!