Sketchup doesn't work properly!

Hello, does anybody have the same problems… suddenly when i work on project, sketch-up program shutdown and i just get warning that some bug happened… but the mostly why I’m mad because didn’t save my work at all … and i check my settings, auto save every 5 min… and after all i gor this message too. why is this happening… i lose all my last work ;(
Screenshot 2023-01-02 at 16.09.21

1 Like

Can you try going to the file on your hard drive. Right-click and select ‘Get Info’. At the bottom there is a lock where you can unlock your file. You may need the computer’s administrator password.

1 Like

The message tells you that the file has been opened as read only.

I deduct that the file is viewable.

If this is so, can you save it with another name (Save as …)?

Or you may be able to copy the whole model and paste it in another SketchUp file, then save it as you wish. Use “Paste in place” to be sure that the model is at the same location as the original one.

1 Like

Are you saving your files locally on your hard disk? I’ve seen that locked message sometimes when I download a file from a file sharing server, as if either the share or perhaps Finder or Gatekeeper holds onto it for a while. The suggested methods of copying or saving then reopening have worked for me.

1 Like

hi, on hard disk.

Have you tried the suggestions made by @jean_lemire_1 ?

From your profile I see that you use SketchUp (SU) 2022 on Mac OS Ventura.

I read a few posts recently on this forum that mention problems with this combination.

The choices are to use SU 2022 on Mac OS Monterey or wait for SU 2023 that should work correctly on Ventura.

Another possibility would be to create a partition on your hard disk and install Mac OS Monterey on it and then SU 2022. I am not sure if this could solve your problem until SU 2023 becomes available. Some users that are more proficient with kind of installation may chime in.


Not yet!

As @jean_lemire_1 states this is likely due to you upgrading your OS before checking if your SketchUp version is compatable with that new OS.
I suggest that in the future you be more carefull before upgading your OS and check if your other softwares are compatable, and not just Sketchup!

1 Like

HI. Yep, I get this all the time. It’s not Ventura related as I am on Monterey. My active project files are local.

This kind of thing can happen if a file backup/cloud sync is running on the file as you try to use it.

Google Drive/DropBox/iCloud drive etc

It is potentially more common on ventura as when you install it, it asks you if you’d like to turn on icloud drive. This is applied to both anything in the documents folder or your desktop.
I don’t think previous versions of OSX asked for it to be switched on in such an obvious fasion.

Wait for the file to finish syncing or Try disabling any file syncing software you have and try again.

Another harmless, yet often effective thing to try is repairing your disk permissions
How to Repair Disk Permissions on Mac (


Interesting that I never once had experienced this on High Sierra (the OS I came from to Monterey) and had iCloud sync settings as I do currently.

That maybe points towards it being someting else then.

I have my work mac on Ventura and everything is totally fine, but I’m troubleshooting users daily on previous OS’s with issues - something that is common among them all feels as if it has changed to start creating these types of issues.

My Mac is basically the out of the box setting and only SketchUp is installed, so I suspect I’ve not caused the OS issue on mine that many are having.

1 Like

Sorry, just to be clear. My Monterey OS was on a clean out-of-the-box MBP M1 Max.
The High Sierra was on my previous machine where I was running SUPro 2019.

The main (regular issues I have) are this one and the ‘unable to save the file, save as a 2020 version instead’ :man_shrugging:

1 Like

Whenever I work on a file that was saved on the cloud, I download it to my hard drive first, then work on it and save it and finally upload the saved file back to the cloud. I know it is an extra step but my files can be large and I like to save often. It has happened that I am saving more often/working faster than the cloud can sync.


This happens to me on Windows sometimes! @jean_lemire_1 had it right, just do a Save As… to make a copy of the file then you can keep working. You could also try closing Sketchup then reopening the file, I think sometimes Sketchup thinks the file is in use by someone else when it’s just you!

1 Like

I occasionally get a “Locked File” pop up on my Mac system. Oddly, I can ignore it and continue working, it seems to have no effect, the file saves just fine.

1 Like