Sketchup disregards formula when scaling dynamic component to exact length

I created a dynamic component for a cabinet consisting of multiple panels. I set it up so the panel thicknesses and relative positions are fixed.

If I use the scaling tool and just click, the cabinet scales correctly. If I use the scaling tool, click, and then type a dimension (e.g. ’ 36" '), the scaling is done without regard to the formula, and the panel thicknesses change. If I then scale again, but just type “1”, Sketchup fixes all of the panel thicknesses.

Anybody else see this bug?


please attach an example, you may need use “current” formula

Here’s an example.

The first (big) cabinet is just how I copied it from my other design.

The second, I scaled just by clicking. It’s fine.

The third I scaled by clicking to scale, and then typing ’ 10" '. It’s distorted.

The fourth is a copy of the third, and then scaled by ‘1’. It’s fine again.

Bad Scaling.skp (120.5 KB)

I believe that this has been documented before, it is a bug, so when scaling put the measure in first before second click. Otherwise do a redraw (right click menu, dynamic components,redraw) you could set a short cut, via the window/ preferences, (provided you have a dynamic component selected) say “w” so that after any scaling you press the w key to assure its redrawn

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.