Sketchup dimensions won’t render in Layout 2018 vector or hybrid

bug

#1

Has anyone solved this issue? I just got around to “updating” to 2018 and my SU dimensions are unreadable in Layout. Yes, I could change them to a point size, or use Layout dimensions. I’ve tried those and they don’t work well for me.

Sorry, I didn’t know how else to respond to a closed topic.

My system:
SU 2018
Intel Core i5-4590 @3.30GHz 3.30 GHz
9.00 GB
64-bit
Windows 7
AMD Radeon HD 6450


#2

How about sharing a LayOut file that shows what you are seeing?


#3

Dave,
Attached is the Layout file (the SU file was too big but I could send it in a separate post).
Just click on Raster to see notes about which are 12 point Tacoma and which are 1 1/4" Tacoma.
I also show a couple of LO dimensions. The one that says “36” Test is WRONG. It did not update when I changed the SU file due to the fact that I added text to it.

I much prefer dimensions in SU for that and several other reasons.

Thanks very much for taking a look at this.
Ron

test1.layout (3.5 MB)


#4

Some of your dimensions are basically in the wall with the towel rack so the wall face conflicts with the dimension text. Moving those dimensions away from the wall, such as out to the near end of the vanity will allow them to show. Here I’ve moved the 8" dimension away from the wall and you can see if shows up just fine.

Although the text with one of those dimensions says it’s 1-1/4 in. tall, the setting shows it at 1 in. tall. Setting your dimension text so that it is 1" tall means that in the scaled viewport (at 1:12) the text should be 0.083 in. tall. It’s there in LayOut. It’s just scaled down so small it can’t be read. Notice the sort of fat parts along the dimension lines.

Unfortunately I don’t know what else to tell you. If you leave the dimension text set to a point size instead of setting the height in inches, it’ll show up as that point size in LO instead of being scaled way down. And keep the dimensions out of the walls and they’ll show up, too.

I guess I don’t see the need to break up the dimensions to add text. You can add text next to the dimension without ruining the dimension in LayOut so that it remains a dimension connected to the model. But, if you still prefer to add dimensions in SU, just keep them out of the geometry and use a point size instead of a fixed height.

FWIW, here are two examples of a dimension with text in which the dimension is still attached to the model and will update if the model is modified.


#5

Hi Dave,
I read your post very carefully a couple of times. Yes, I saw the tiny print in the dimensions originally. It’s there, but too small. I don’t think about scale very often, but shouldn’t those letters be about 3/32" tall (1:12 scale means 1"/12 = 3/32")? If they were 3/32" they would be just fine. Also, note that the arrow heads are the right size. It’s just the TEXT that’s small.

Thanks for the tip about dimensions in walls. I need to get my dimensions to snap to the section lines. I’m hoping SU 2018’s sections will allow me to do that.

I think the real problem is that LO is scaling my dimension text down for reasons I don’t understand.

Here is a new set of files:


(It was too big to attach)
This was created with LO 2017. When I open it in LO 2017 the dimensions are just fine. BUT if I load it into LO 2018, they look fine at first, but as soon as it redraws (click on Raster, then Vector) the dimensions get reduced. Even worse, it seems I can not export to PDF once it reduces the text. I guess it refuses to print tiny text.

It seems like there’s a difference between LO 2017 and LO 2018. Or maybe there’s a setting that I have different from one to the other.

This same problem was reported by someone else a few months ago with the same subject I used for this post (it had been closed out, or I would have replied to it).

I really appreciate you taking a look at this. You understand Layout a lot more than I do.

Thanks,
Ron


#6

I just started from scratch on the Vector vrs SU dimensions problem. I created a very simple model in SU 2018 and imported it to LO 2018 (no 2017 involved). I’m attaching them, and here’s a screenshot:

The Problems:

  1. The fixed height dimensions from SU show fine in Raster mode, but are very tiny in Vector mode. (I tried increasing the font height to a huge 20" size but only the arrows get bigger in LO). Leader text has the same problem, but Screen text does not.

  2. “Export to PDF” does not work at all if there is tiny text in the drawing. (It works fine if I change to Raster, or use Vector and delete those dimensions.)

This sure seems like a bug to me.

test 2.layout (134.2 KB)
Test 2.skp (32.7 KB)

Here’s a link to Brent Nyquist’s original post on Jan 6, 2018 with the same subject.:


#7

I guess I can’t give you a specific answer to the question of the tiny dimensions, Ron. That’s probably a question for someone on the team like @trent.

I’m not understanding why you find dimensions in LayOut unusable, though. There isn’t any reason you can’t add the dimensions you show in LayOut.


#8

Thanks for all the tips and for being patient with me. I will now try to switch to LO dimensions. And I’ll tell @Trent about what I see as a bug.

The main reason I started using SU dims in the first place was that LO dims were not linked to the model at that time. I started with the Pro version (2016), so it wasn’t that I didn’t own LO.

I need to go through a LO tutorial. Right away I see that the dims don’t move with the model they’re linked to when you move a view apparently you have to select them separately.

Thanks again for all your help.


#9

It’s correct that LayOut dimensions weren’t linked to the model in older versions but that’s not the case anymore.

If you want to move the viewport around on the page, you can select it and the dimensions together and move them en masse.

While it is possible to open up the viewport and orbit, pan, or zoom the camera, it’s not a good practice because it modifies the scene in LO and disconnects the viewport from the SketchUp scene. There really isn’t any reason you should need to do that, anyway.


#10

You got me thinking, and I remembered the real reason I was so intent on dimensions in SU not LO. At first, I did my presentations to the client IN Sketchup. They LOVED it. They’re looking at in 3D and I open cabinet doors and drawers and even toilets just for fun. Some architects like it, but they still always want 2D views like they’re used to. Also, I really like the idea of one file only not three for a given room (skp, layout, pdf). These days I interface more with architects, so I’m learning Layout.


#11

Hi Ron and Dave, yes this is a known bug with 2018 where text in SketchUp with a fixed height value for example 1’ is being passed into LayOut at that height. So when this text created in the SketchUp model space is passed to LayOut paper space it is being displayed at the actual 1’ height.

Our only work around for when using dimensions or leaders from SketchUp into LayOut is to assign a comparable pt. height.

So with your file I assigned a pt. height of 10pt for the dimension font height and it displayed and exported from LayOut similar to your original set height of 1".

And as Dave has stated you will have more control of style size etc… dimensioning within LayOut.

Sorry for the inconvenience this has caused and know that we aware of the problem.

Trent


#12

Thanks Trent. Your work around is VERY helpful. Also it’s great to know SU is working on it.

Is there someplace where known issues are listed? Dave and I could have saved a lot of time…

I feel I should explain why I use SU dimensions. I want the client to view the job in Sketchup not PDFs. That way they can move around, open doors, (and see dimensions). The emphasis is on the model itself. The (boring) dimensioned elevations and plan views are just there for the architects, or if someone needs to look up a measurement. This is the whole reason I got into SU. An architect sent me a 3D SU model that was worth a million words.

Thanks for your help Trent AND Dave


#13

Trent,

Does SU have a timeframe estimate on this fix? I own a design build firm and we do all of our drawings for the city in SU and this is a huge issue for us because our electrical plan is not legible once loaded into LO. It would not be much of an issue if I had access to the electrical symbols in LO as I could build this up within the platform. I have 3 new builds that I am about to start the electrical on and need a work around, or solution ASAP(…like today, but I understand this is not the case). Does SU 2016 or 2017 not have this issue? I have both and can down save the file into either if that would work for the time being.

Thank you for your help,

Rucker


#14

Sorry for the delay, 2016 & 2017 did not have this issue. I wanted to let you know that this has been fixed with the SketchUp 2019 release.

Trent


#15

Thanks Trent,
Ron