SketchUp (desktop version) thinks you don't have an Internet connection

I’m connected to the internet but getting the “can’t connect” error from SketchUp 2023.

I can’t find the file to fix on my Mac. (I’ve fixed it on my PC)

Sketchup help says: For Mac users, the equivalent path for the PrivatePreferences.json file is here:
~/Library/Application Support/SketchUp 20##/SketchUp/
(replace 20## with your SketchUp version number)

But there is no “Application Support” in my library. I can’t find a “PrivatePreferences.json” file.

I found an i18n.dat file but it doesn’t have anything about the website in it.

Make sure to copy and paste the whole path into the Finder, Go, Goto Folder… dialog:

~/Library/Application Support/SketchUp 2023/SketchUp/

The ~ at the beginning is important.

Hi @colin,
I hadn’t used SU2018 for quite some time, but a plugin customer mentioned problems using “Add Location” and I came across this thread whilst troubleshooting.

At first I received the no internet connection error, which was fixed by setting
ONLINE_TEST_URL=https://www.sketchup.com
(Google didn’t work)

Now the online services still don’t work. For Extension Warehouse and 3D Warehouse I get a message like this:
image

For a “Add Location” it is just a blank white window. I recall reading elsewhere there were also issues relating to old SketchUp versions and the legacy agreement with Google to use their maps/geolocation services expiring.

thanks
Dave

The EW and 3DW policies changed to be three latest versions only for access from within SketchUp. You can still reach them via a web browser and download from there, but not directly from within SketchUp. Also, the 3DW only offers dae downloads for old versions. You can download the dae and import it into an old SketchUp.

Google changed its terms of use a number of years ago and SketchUp no longer gets image or terrain data from them, using other sources instead. I don’t know if that causes the white screen you are seeing.

2 Likes

What Steve said, the online services support for 2019 and earlier was stopped at the end of January.

If you do download a DAE from 3DW in a browser, in the import options make sure to check the box that says Merge coplanar faces. That will bring the model in looking as good as if you had downloaded a SKP version of the model.

Hi Colin. I’m experiencing this in my Sketchup Pro 23 ver. Checked the thread and located the .dat file but it does not include the part that has the online test url.

My guess is that your problem is different from the one that concerned version 2018 or older. I would look for things in your antivirus and firewall settings that prevent SketchUp from accessing the Internet. @colin can tell which ports should be allowed etc.

Later versions store the URL to check in a different file. In File Explorer, paste in this path:

%LocalAppData%\SketchUp\SketchUp 2023\SketchUp\

Edit the file named PrivatePreference.json, and look for this line:

"OnlineTestURL": "",

Put your test URL into the last quotes on that line.

2 Likes

This one worked. Thanks for the suggestion!

SKP Pro 2018 on mac changing to bing doesn’t seem to work anymore in order to add license on new MBPro M1.

I think you have a different problem. The one where there appears not to be Internet would have stopped you before being able to try a license.

The other problem that could be what you’re seeing, is that if you have activated the license three times, it used to say that you have exceeded your allowed activations. These days it fails silently.

You are not able to add the license because it is already activated on three other computers. To activate it on a new computer you would need to remove the license from one of the three old computers.

You might be right about those 3 activations. I would be happy to deactivate that, but the other problem – I cannot find my Trimble account that would show the purchase. The e-mail I got the serial from reseller doesn’t seem to be connected to Trimble. Don’t know how to solve it.

You can’t deactivate the license remotely. You need to open SketchUp on the old computer and remove the license.

If there is a reason you can’t do that, you would need to contact support and see if they can do anything to help:

https://help.sketchup.com/en/contact-support

I did remove the License on old machine yes. After that I have deleted the sketchup from it as well. But it doesn’t start on the new one.

Activations and deactivations show up in our system. The last deactivation you did was in November 2022. If you did a remove license more recently, contact support and tell them the date you did that, and that even after removing the license you’re not able to add the license to a new computer.

Great success, Kevin from support did reset the activations and now SKP2018Pro is running again. Thank you very much Colin!

Hi Colin, I have accessed PrivatePreferences.json (on Mac) but cannot find the “OnlineTestURL”: portion. Any help here?

That looks like the preferences before SketchUp has ever been run. You could open SketchUp, start a new document, close SketchUp, and that file should then look a lot more filled in.

The ‘Preferences’ section may still not include the ‘OnlineTestURL’ entry, but you can add that yourself, while SketchUp is closed. It doesn’t matter where the entry goes, so in the case of what you showed so far, now it is:

        "Preferences": {
            "LastUpdateCheck": 0.0,
        },

you could change that to be:


        "Preferences": {
            "LastUpdateCheck": 0.0,
            "OnlineTestURL": "https://www.bing.com/"
        },

and do a save. Then SketchUp would use bing.com when it checks to see if you ar online.

Hi Colin, thanks for the speedy feedback.

I am unable to even login via the downloaded app and run the program. All I am getting is that I am offline upon the initial download, completely blocked from starting anything up (See attachment).

Thinking about it, 2023 defaults to using Bing anyway. It may be that bing.com is blocked on your computer. Try using a different URL when you edit the preferences file.