Sketchup crashing every time i use subtract! help please!


#1

hello, i had a very bad start when i started to learn and use sketchup, after i made my model and wanted to finish it with subtracting, its just crashing! i tried to install older version of sketch up and its the same problem! i tried to install a new windows7! and the same problem! i have Geforce gt 630m 2Gb, intel core i7 quad core 2.3 Ghz, 8 Gb of ram, and all up to date!
help me please!


#2

Can you share the sample model?

Also, did you submit the BugSplat? If you did, did you enter any info in the Description box, name or email that we can use to look it up? If you didn’t, can you submit again with some info we can use to lookup the BugSplat report?


#3

hello dear, this is the model:
https://drive.google.com/file/d/0B7W8EpePWKyaREVFV0c1aVdObjQ/edit?usp=sharing

yes i submit the Bugsplat many times, and wrote my info.
thank you


#4

sorry, i made it accessible now.


#5

Hello Rajaa kahel,

I see two problems:

• The model is very tiny.
Scale the model up x1000 > Subtract > Scale the model down to normal size
But before you subtract there’s another problem you need to fix.

•The smaller component (#7) is poorly modeled.
Notice the cylinder portion is not perpendicular to the rectangular portion.

There are extraneous edges and interior faces that should preclude the component being deemed ‘Solid’
It is definitely not a Solid, even though Entity Info identifies it as a Solid.
I believe the tiny size of the model is the root of the problem here as well.

-Geo


#6

dear Geo, thank very much for your time, i will learn how to do the model without these lines, i dont know how yet, because when i try to remove a line it removes a piece of a surface also… but anyway i think there is a technical problem because its crashing… i will try with your advice, thank you (:


#7

What info was that? Can you tell me part of it so I can search for it?

The small size of the model should not lead to a crash. Nothing should lead to a crash.
If anything, the small model size might be expected to fail the operation if it’s too small for SketchUp tolerance. But crashes are clear bugs in the application and not a user or model error.


#8

It’s obvious the little component (in my screenshot) is definitely not a Solid.
However, Entity Info says it is a Solid. That is certainly incorrect behavior.

This is the first time I’ve seen Entity Info label a non-solid component to be Solid.
My guess is the tiny size is making it to difficult for SU to detect the geometry that makes it not a solid.

Building teeny tiny geometry usually causes not so tiny problems.


#9

dear tt_su thank you for your help, i wrote my email: rajaakahel@gmail.com, and my name: Rajaa Kahel


#10

SU is limited in creating new geometry smaller than ~1mm
It was developed for modeling architecture, not the tiny parts of a watch.

Scale the model up x1000 and carefully model a new solid component.
Don’t bother trying to fix the bad geometry of the old component.
Simply delete the old one and purge the file.

Then try the Subtract operation.
Scale the model down x1000 when you have completed the model


#11

thanks dear, but since the hard work with these lines and the not working subtracting, i tried a new software 123d Design and here you go! in minutes every thing done! im very happy now!


#12

That certainly is odd. This bug appear to come with friends… :stuck_out_tongue:


#13

I see from the BugSplat report that the crash is happening inside the boolean operation. Something is amiss there.
I’m filing a new bug.

Can you describe how you trigger the crash? You said you use the Subtract function, but with what geometry? You subtract something from that small component, or you subtract something with the small component?

I’m also filing an issue for the “Solid” claim in Entity Info.


#14

i subtract the small thing from the big thing, when i click subtract its crashing.


#15

Hello Rajaa kahel,

It would be best if you would share the model again.
Set it up the exact the way you want it just before the Subtract operation.

-Geo


#16

Here is an example of a “solid” that probably should not be classified as a solid. It is just 2 solid cubes that do not intersect. Not a size issue.


#17

Well, that’s enlightening and distressing.
Would you call it a “finite closed volume”? http://help.sketchup.com/en/article/1011019


#18

Right, what is happening here is that the solid test is very naive - it only checks that each edge has two faces attached. That is probably done for the sake of performance.


#19

And if you add another cube as a second solid, then run the outer shell, it clears out the internal lines from the first two cubes.

Shep


#20

I agree the small size isn’t the only thing hampering the OP’s efforts.
Merely scaling the model up x1000 or x10000 doesn’t help; the Subtract operation still initiates a crash.
Perhaps the Subtract operation is affected by the OP’s poorly constructed “solid” geometry.

Here’s a copy of the OP’s model. Motor2 Modeling Errors.skp (61.4 KB)
Therein I purged unused components, then added scenes and text pointing to the modeling errors.
The “solid” component in question is far more complex than Jim’s clear-cut cube example.
It’s a tiny component with even tinier off-axes modeling errors.

I made a new model. Motor2 by Geo.skp (302.4 KB)
Therein I replicated a clean truly Solid version of the so called solid component in question.

The Subtract operation doesn’t crash SU; but as expected, faces fail because the geometry is too small.
Subtract works perfectly after scaling the model up x1000.

I agree, Thomas. It’s confusing.
Jim’s cube example and the OP’s problematic “Solid” component illustrate that there’s a conflict.

-Geo