Sketchup crashed, I saved progress but 4 hours work lost :-( help!?


#1

hey all,

SketchUp Pro 2016, 32bit, Win7

i was working away and i dont recall exactly how it crashed but ■■■■, I’ve lost 4 hours work!!

Im not even sure i was doing anything stressful, i think i was just tidying up lines with the eraser tool!

i saved it many many times, but after the crash, the saved file in windows explorer shows no sign of a recent save (date modified)!!!

but i know for a fact i saved it over and over.

am i able to restore my hard work, what on earth has happened, when it came to ‘send crash report’ i said ‘not now’ (words to that effect), because i was just desperate to keep working and load my saved work again. -but thats when i noticed the failure.

-any techxperts care to help - does sketchup keep any temp working files anywhere??!!?

I dont want to touch anything more until ive tried to get some help.

-sketchup has also reset my tool layouts.


#2

Maybe you saved to another directory than the one you have now been looking in. If you haven’t disabled it there should also be backup files, with the extension .skb, in the same folder as the file you are working on.


#3

Thanks for the suggestion.
Yes, i had that thought, and did a search on entire laptop for skp, skb

It’s really incredibly bizarre to be honest.
Is saved it multiple times over the 4 hours I’d been working, but the skp and skb files in Windows explorer so not reflect that. Instead, they have a date and time much earlier.

It’s like the SketchUp crash actually effected the files themselves -i don’t even know if that’s possible! :smiley: i would have thought no way possible, but i know for a fact that i saved multiple times.

So bizarre. I started thinking… hmmm… Maybe hard drive failure in some way?

I’ll probably just redo the work, i guess best case scenario it reiterates the learning.

Ps - fanstastic castle by the way.
Is it part of your architecture studies?


#4

if “Window > Preferences > General > Auto-Save” was enabled during the crash an auto-save file should be created in the concerning directory with “AutoSave_” prepended to the file name (e.g. “AutoSave_.skp”). Unfortunately it get’s deleted if you open the same (old) file and exit SU the normal way


#5

I think I’ve seen someone posting about the same problem before.

Perhaps some internal issue occurs in Sketchup, that isn’t visible to the user but prevents saving, and then much later lead to a crash. Usually programs are coded to stop when they discover they’ve done something wrong but perhaps something happens internally in SketchUp that isn’t detected.

It’s also possible something outside of SketchUp isn’t working, e.g. file synchronization, network or the like. Are you using Dropbox or any other similar service, or maybe a network drive?

Just thinking out loud.


#6

or an external flash-based device (USB stick, SD card)?


#7

all very helpful thoughts, thank you.

But no this was just on an internal hard drive of a laptop.

@sketch3d_de interesting info about that temporary auto-save.
I do indeed have auto-saved selected. I might start making copies of saves in future.
It’s a pretty severe bug.

@eneroth3 thank you for the ideas and chiming in. Next time ithapens (god forbid) I will submit a report.

Here we go! - about to model it again! :slight_smile:


#8

as always: save early, safe often

preferrably by a “Save as…” and incrementing a counter for keeping several revisions as e.g. “<mymodelfile>.01.skp” … just in case :wink:


#9

Or “Save a Copy As…”. It does the same thing but automatically increase the number and let you stay in the old working file which is quite nice when you link it from LayOut.


#10

This topic was automatically closed after 91 days. New replies are no longer allowed.


I could use some support, I just lost 6 hours work