Sketchup crash, when I draw a line from one point to another

Sketchup crash when I draw a simple line from one point to another plz help its urgent

Try going into Preferences > Open GL and disable fast feedback.

What version of SketchUp are you using? Your profile indicates SketchUp 2019 Make which does not exist. What is the actual graphics card that Sketchup is using? Look in Window>Preferences>OpenGL>Graphic Card Details.

Did you install SketchUp correctly? That is, did you right click on the installer and select Run as administrator from the Context menu?

disable but same … my model is almost complete but i need to draw some more lines … when i draw line on that particular area where i want it crash and close … if i draw line on different area it wont crash

disable but same … my model is almost complete but i need to draw some more lines … when i draw line on that particular area where i want it crash and close … yes install it correctly

I already check my file on other system but crash on same point … i just start my project all over again but when i draw line on that point its close …

So it sounds like there’s some problem with the file. How about sharing it so we don’t have to guess?

As before, what version of SketchUp are you using? You have yet to correct your profile which shows a non-existent version.

Have you tried Model Info > Statistics > Fix problems ?

How can i share my file to u ??

Click the Upload button or just drag the SketchUp file into your reply. If it’s too large to upload here, upload it to Drop Box and share the link.
Screenshot%20-%209_30_2019%20%2C%207_14_02%20AM

DESIGN 2.skp (2.6 MB) Design

I am really thankful to you if get me out of this … this is my thesis work

At first look I see a couple of major problems you’ve created for yourself. First, you haven’t been using groups or components. Then entire model is loose geometry. Second, you are using layers incorrectly. ALL edges and faces should be created on and remain on Layer 0. More investigation.

I see the crashing without Bug Splats when I attempt to draw an edge in the model, too. I’m not seeing what the cause of it is, though. You’ve got something corrupted in the file. I’ve tried copying the geometry to a new file as well. Maybe someone from the SketchUp team can look at your file and diagnose the problem.

If you just want to draw that edge, then use Rotate tool and ctrl:

But your model needs major repairs, which means it’s easier to redesign it from scratch.

As a workaround to get you moving, double click that specific face, assign the selection to Layer 0 and then make it a group.
You will then be able to work without it crashing.
But you still need to fix all the layering and grouping.
There is something very strange with the model.

When I open this model, SketchUp says it was last saved with version 15.0.1 but your profile says you are using 2019 Make (which as DaveR noted previously does not exist). What are you really using?

Unlike the others who responded, I can draw that line on my Mac with SketchUp 2019.2 without a crash, so there may be something sensitive to Windows?

As others have pointed out, there are multiple issues with your model even without the crash that suggest you are not using SketchUp correctly:

  • With the exception of a couple of instances of Chris, the model is all loose edges and faces. You need to learn to use groups and components to prevent SketchUp edges and faces from sticking to each other. Your use of layers suggests that you expect them to isolate edges and faces, but that’s not how SketchUp’s layers work. They only determine visibility, and visibility does not affect stickiness.
  • All except for the instances of Chris, the model contents are located pretty far from the model origin. Why?
  • All those gray faces are showing the back side, vs the white ones showing the front side. You should reverse them to avoid potential issues later, especially if you apply materials or do a rendering.
  • There are some things that hang below the ground plane. It isn’t clear whether that was intended or is a mistake.

yeah u are right i just try different options so i saved this file in earlier version … i tried 2015 2017 2019 but same problem.

Thank you sooo much … now after group and component everything is smooth now …

1 Like

Thank you so much

Thank you so much fix now