SketchUp crash error

My problem is every time I start the program a Bugs window opens and it is impossible to continue. The only way that I can use SketchUp is when I start my PC and as soon as the display starts I must do double-click on the SU icon before nothing else. (and I assume before AMD driver load finish).
I tried to erase the AMD driver and reload the latest version of it…but it is the same.
My system is pretty new (6 months)

CPU Intel(R) Core™ i7-9700K CPU @ 3.60GHz 8 Cores
64Gb RAM
AMD Radeon Pro WX 3100
Do I have to change to Nvidia 3060 ti to solve the problem? Is there another graphic card to recommend?

Are you sending in the Bug Splat report with something that identifies it came from you?

Did you install Sketchup correctly by right clicking on the downloaded installer and choosing run as administrator?

Hello DaveR.
Yes, I did it. I sent to Bug Splat the report with my email address and I installed SU as administrator. When I manage to open SketchUp, I can lock it quietly… but I have to open it as soon as I turn on the PC. Otherwise, I have to restart my computer and quickly start SU.

Well hopefully @colin can take a look at the Bug Splat report to see what it indicates. He’s apparently traveling at the moment but when he gets home I expect he’ll be able to check for you.

I only see one report from you, and that was four weeks ago. Is that the last one you sent in?

Do you use Space Mouse at all?

Hello Colin,

I am also having trouble accessing SketchUp Pro 2022. I have also downloaded as an administrator with no luck. I have sent a couple error msg’s in from

I appreciate any support you can provide.

Do you get a crash if you only use one monitor?

Thanks for your response Colin!
Yes, so far I am only on one monitor.

Hello Colin
Just one report???.. I have sent reports since I bought my PC in July 2021. I manage 2 monitors with my PC. I didn’t try with one monitor. But the question is if I must change my GPU and if I do, what is the recommended GPU. I have problems with Autocad and Twinmotion too.

I was set to only see the last 30 days. Now I see the long list from you.

Doing a one monitor test would let you know which GPU is working, if there is no crash. Setting both monitors to use that GPU might stop the crashing.

Is there a reason you are using 2020.0, and not 2020.2? I don’t think it would solve the crashing, but might fix other things.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.