SketchUp Clipping

Frustration with SketchUp clipping is well documented. Indeed, Daniel Tal has an $89.99 ClippingPlane extension that apparently delivers a “one button” solution to the problem. And SU4 has a Fix Clipping Camera extension on the sketchUcation website that gives you access to a Camera window … where you can manually adjust camera settings to resolve the problem. This is old news … and there are already a variety of threads on this forum that explore the topic of clipping … and these extensions.

But, as far as I can tell, no one can explain what to do to avoid clipping in the first place … other than generalities about avoiding Parallel Projection … and ensuring that the model is close to the origin … et cetera. And for years this has been sufficient for me to avoid the problem. But this evening I was working on a very pedestrian architectural model … making some small changes to a cabinet in the interior … and suddenly SketchUp started clipping.

As far as I know I had not inadvertently moved the model away from the origin … or added some extraneous geometry at some distance from the origin … although with my keyboard skills (or lack thereof) anything is possible. It seemed to me that SketchUp just started clipping.

After perusing some of the current threads on clipping I saw a suggestion about copying the model into a new SketchUp environment. So I copied the entire model … and sure enough … NO clipping. As far as I know the ONLY thing missing from the new environment were the Scenes … and I suppose the Styles … from the “original” model.

After that I opened up SU4’s Fix Clipping Camera extension … modified a camera setting or two … and was able make the clipping disappear.

Great!

But … and here is the point of this post … what had I done to make SketchUp START clipping?

And why are the camera settings so widely different … on the two models that are essentially the same?

This first screen shot obviously has clipping. This is the original model.


The second screen shot is of the SAME model, copied into a new SketchUp environment. No clipping.


Can anyone tell me what I did to the model to cause SketchUp to start clipping?

And … is there any documentation available on what these various Camera settings/parameters mean?

Also … no I will NOT upload the model … because it is work product for a client. I would gladly work up a simple model that exhibits this same behavior … if I had any idea of what I had done to trigger the clipping.

So there you have it. What are your thoughts on this topic of what I did to trigger the clipping?

OK. I may be slow, but at least I’m not fast.

Zoom Extents showed that I must have inadvertently added something a great distance from the origin … because the model is very tiny, at the origin. How it got there … I have no clue. Undoubtedly the result of poor keyboard skills. Regardless, @Anssi, @DaveR and countless others have patiently pointed out on numerous occasions … these “big” models can be afflicted with clipping.

OK … so how do I get rid of something that I can’t see … when I don’t know what it is … or where it is?

Since my model really is at the origin … it is relatively easy to select all of the model.

Then … invert selection … and delete. Appears to work … at least for me … in this instance.

Screens shots tell all.

Clipping.

After deleting the unknown, unseen geometry … a great distance from the origin. No Clipping.

I post all of this in the off chance that it might save some poor soul some time … sometime in the future.

SketchUp’s clipping is an undocumented feature, it helps you to see inside your model without having to create section planes, and it updates dynamically!

It will be on the list of official features of SU2021.

:yum:

2 Likes

Clipping is the SU version of hiccups. Everyone gets it at times, everyone is annoyed by it, no one knows why it happens (or if they do, they can’t cure it so they don’t mention it), but it is always lurking ready to pounce at the most inconvenient moment.

Maybe the genius that discovers the Grand Unification Theory will use a coffee break to solve this one too.

I find clipping entirely predictable and have yet to find a model where I couldn’t point to the cause of the clipping.

3 Likes

I never find it a problem. Isn’t there a text anomaly that could be the cause of the far-off -object issue?

Actually it’s cool to use with the position camera tool to see a quick interior elevation or ceiling plan. ( In parallel projection drag the position camera tool toward a wall or up a wall.