Sketchup auto-save causes screen freezing

Hello, my screen freezes whenever SketchUp auto-saves my work.

I had it set to auto-save every 5 minutes and every 5 minutes I had a blue ball appear for 30 seconds. I have now set it to 20 minutes auto-save. Is there any guidance on auto-save and is it normal for it to freeze?

Many thanks, Monika

How large is your SketchUp file? SketchUp won’t respond to input from you during an autosave. If your file is huge the save can take awhile. You might try purging unused stuff once in awhile to help keep file size down.

Hi DaveR, it is not that big, working on furniture for a house just now. I’ll check how it works with really small files and come back to you.

How big is not that big?

Can you share the Sketchup file?

I have auto-save disabled to avoid the delay that occurs when saving a file with lots of geometry (100K+ edges, say), especially when the check-model-validity-on-save feature is enabled.

Another reason to avoid auto-save is because I recall reading posts that say the resulting SKP model file can occasionally be corrupted if the save was triggered while SketchUp was in the middle of some big operation. That never happened to me, and I may be misremembering the older posts.

I manually save fairly often, such as when some tricky sequence of modeling is done or I’m about to make a big change that I might not be able to undo (the undo stack is too small), etc. I also use the computer’s operating system to save copies of the current SKP file every now and then (macOS Duplicate in Finder), in case I want to go back to some significant previous state.

And If it’s not because the file is big, it may be something permissions related and it can’t save to the area where those backups go.

OR another backup/cloud storage system is locking the file as sketchup tries to write to it

Thanks for your response. I’ve changed the auto-save to 30 minutes, it if start causing an issue, I will consider disabling it.

Thanks Adam, following your response I saved the model locally, but the issue is still there. I’ve extended the auto-save duration, let’s see how it goes.

DaveR, yes, plese see as attached.
Uploading: Stats.JPG…

241 Mb is not a big file?

1 Like

How does this compare to large architectural buildings?

241MB is a very large SKP file, which implies either lots of very large images, textures, etc, and/or many millions of edges and faces. For what it’s worth, I have been working on a highly detailed model which has of the order of 10 million edges, consuming ~260MB on disk (using the original uncompressed pre-2021 format). It takes about a minute or a little more to save (with validity-check enabled). If your file is about that size, but using the 2021 compressed format, then I wonder how much geometry (or images) is in it? If you open the Model Info window and look at the Statistics area, it will summarize the edge and face counts in your model (if the “Show nested components” toggle is enabled).

1 Like

I expect your model could do with some cleaning. I’d be willing to take a look and see what can be done but you turned me down on that.

Thanks for the info, I have managed to resolve the issue for now.