SketchUp and macOS Mojave (10.14)

macos
mojave

#62

First search result in this search is what I used: https://3dwarehouse.sketchup.com/search/?searchTab=model&polygonsMin=150000&fileSizeMin=40. If you click on Materials in 3D Warehouse, you’ll see that there’s two > 1MB brick materials in the model.


#63

Soooooooo…

With my head held in shame, I checked and discovered that in Sketchup I was using a Style with Profiles on!!! Switched that off and Sketchup flies! Consider myself fired.

Layout still slow and jumpy to zoom.

I have my fingers and everything else crossed that V19 rectifies this, as I rely on it so much.

Mike


#64

Have you updated that model in LayOut, or tried sending that model to a new LayOut document with Profiles off? I still don’t think it’s Mojave. Is your model bigger than the one I tried? I’d keep searching. Can you share the LayOut file either publicly or privately? Can you “Open in SketchUp” from the LayOut file to be really sure it’s the same model?


#65

Hi @Barry

It does it with any size model. Layout template with no viewports in is fine. As soon as I import a model, the zoom is killed.

Here is one of the models;

The line style makes no difference at all. This model is only 3.9MB. This model and Sketchup works fine on my MacBook Pro which is running OS High Sierra. This iMac came with Mojave already installed. The operating system is bang up to date too.

It’s so frustrating as Sketchup works fine. This is a brand spanking new iMac, 40GB RAM, i7 4.2GHz Processor, 4GB GPU, 512MB SSD.

Edit: Also, the model and Layout file were created on my old iMac, running High Sierra and 16GB RAM, i5 Processor. No problems at all.

I really don’t understand it.

Nothing much installed on it either, as it only arrived yesterday.

I am really panicking about this. At the moment at least I have my MacBook Pro to fall back on.

Mike


#66

Hi @Barry

And here is the Layout File, only 5.9MB.

Mike


#67

I’ve even tried changing all the viewports to Raster. No difference.

Mike


#68

Even just tried creating a new Sketchup File. A simple box. Send to Layout… cue the very slow snails!

Mike


#69

Downloaded the LO file: all work fine for me on AMD on laptop on Mojave. You have your model layer locked, so I had to unlock to select. And the one view that’s not ortho, has fog on. You probably don’t need fog in 2D… or maybe you do, from that camera angle. Either way, no problems. We’re missing something.


#70

Ah, you’re on a MacBook? That I think is the difference.

I’ve tried EVERY setting on my iMac. Been though Activity Monitor, Accessibility options, Display Options, Mouse Options. No difference. Don’t laugh, but I even tried taking the batteries out the old iMac Keyboard, as I thought that might be interferring with the new iMac, as the light on the old keyboard was flashing, and I can’t seem to turn it off.

I just don’t get it. It should fly on this Mac. It’s only 6MB File! It’s GOT to be Mojave on iMac. It does seem to tie in with the previous comments from Mac Pro Owners.

I am absolutely NOT updating my MacBook Pro until this is working. If it is not fixed in the next version, I’m lost as to what to do. Got a brand new iMac, and Layout is useless under Mojave.

Mike


#71

And the model embedded in that LayOut file, by right clicking and opening in SketchUp, has Profiles on, correct:

I only get in that LayOut file what you embed, and since I can’t find the original model on MY filesystem, it shows up in red in File->Document Setup->References. Try this:

So the model you’re messing with in SketchUp and LayOut are the same.


#72

Tried it without Profiles. No difference.

Model references all up to date too on mine. I always make sure they are kept up to date, and I always lock my SU Model layer once everything is in the right place, so I don’t accidentally move viewports.

Everything I have tried makes no difference.

I even tried a new Sketchup File…

1 - Create Simple Box
2 - Save File
3 - Send to Layout
4 - Slow

Give up, (and thoroughly Pi***d off with it all). Feel like I’ve just wasted £2500.

Mike


#73

I do thank you for your help though @Barry. It is very much appreciated.

I just can not think what else to do apart from panic if the new Version does not address the problem. Maybe have to find a different package.

I hope I’m not the only one having these problems.

Mike


#74

AND even thought of trying a different Mouse. What mouse are you using?

Mike


#75

Just an old magic mouse or the trackpad (I always maintain trackpad skills in case I’m stuck). I’ve pinged a few Engineers, and I hate to say it, but I haven’t found another case like this. They’re really using similar code. I’ll walk over and see if I can roust anyone.


#76

And just to check, my Layout is Version…

Is this the latest?


#77

Thank you. Very stressed about this.

This is my machine Spec

Mike


#78

Could not think of another way of sharing this, so took a screenshot.

It’s from another post about Layout.

Mike


#79

We had a 2014 iMac, it worked fine on Mojave. I’ll ping those two for specs. You can copy the url and share a link to the post.


#80

Thank you. Really appreciated.

Kind regards

Mike


#81

SketchUp Pro 2018 M1 for macOS released (build 18.1.1180 from 11/12/2018)

Release Notes:

Fixes for macOS Mojave:
• Fixed a crash that could occur on startup of SketchUp.
• Fixed an issue in LayOut in which the Export Options button overlapped the Format drop down preventing selection of a Format.

Download