SketchUp and macOS Mojave (10.14)



• SketchUp Help Center : SketchUp Hardware and Software Requirements

Don’t expect a compliance of SU rev. 2018 w/ SU 2019 ahead, i.e. probably available before end of this year (typically November).


Please see this post: SketchUp and macOS Mojave (10.14)


Funny, I searched “System Requirements” and did not see anything listed. Now I just searched “SketchUp Hardware and Software Requirements” and nothing listed either… on the first page of 10 results. Then I clicked on Pg.2 and sure enough there it is - at the end. No mention of Mojave.



I’ve just upgraded my iMac to a new one, with Mojave, and while Sketchup Pro 2018 seems to be working fine, the zoom speed in Layout has died basically.

Would be interested in what other people think.



I haven’t observed that personally, but of course that can depend on video driver updates per OS versions, or power management changes. What’s your video card(s)? And are you enabling automatic graphics switching on a MBP? That could possibly slow things. I always disable that setting in System Preferences-> Energy Saver panel.


It’s a iMac, so no options in Preferences for Energy Saving

The GPU is an AMD 4GB.



I haven’t run LayOut 2018 on an iMac running Mojave personally, but next time I’m in the Apple Store, I’ll download and try it unless our usual outstanding group of users has some experience with Mojave + AMD iMac?


I just think it has GOT to be Mojave, (read hoping), as it works absolutely fine under High Sierra.

It’s not too bad on an empty document, but I opened a 5.9MB file and the zoom lag was in weeks.


Looking at the diffs for my AMD drivers from High Sierra to Mojave, using
kextstat | grep AMD

It looks like they version was bumped (1.6.8 for High Serra, 2.0.4 for Mojave).
But on my MBP, I opened a 70MB complicated model, sent to LayOut, and zoomed in and out of the model with no issues.


Hi @Barry

Not sure I understand that, but sounds like it is down to Mojave? Is that your understanding?

If so, fingers crossed that Pro 19 will resolve it, (Roll on Version 19).

I have the same. Perfect on MacBook Pro with High Sierra.



Maybe it’s a sign. You’re supposed to remain light on your feet. Mobile. Ready to move at a moment’s notice. :smiley:


I’m not convinced it’s Mojave. Does it do it with all models in LayOut? Are you Radeon Pro 560 with 4GB video memory? I’m always looking for an excuse to go to the Apple Store near our office.


Its a Radeon Pro 575, 4GB

Yeah, it does.

Opening a template Layout is fine, zooms as happy as Larry. Adding text, and objects is fine, and zooms ok.

As soon as I insert a model, it kills the zoom.

If I open a Layout file I have already completed, the zoom is shocking. However, if I manage to zoom to an area with just text, it kind of reverts to normal.

It can not seem to handle viewports with Models in.



One thing I’ve just thought off…

This new iMac only has 8GB of RAM at the moment. It is an i7 4.2GHz though, so should have the speed.

I’m planning on upgrading to 32GB but didn’t want to select that option when I ordered it as Apple charge a lot for memory.

I can’t imagine why it would make a massive difference especially as the Layout file I opened first was only 5.9MB and the zoom on that was terrible.

Anyway, just a thought.



Ok, I’ll swing by Apple tomorrow and try this out. But my guess will be that they’ll probably pop a lot of memory in the floor models. We’ll see.


Good Morning

So, an update.

Just upgraded the RAM, and now have 40GB instead of 8GB.

Layout is better, but still not quick considering the machine. Still quite jumpy but better than it was. Slow to zoom and jumpy when zooming.



I stopped by the Apple Store, and the lowest-end iMac had a Radeon 555 w 2gb memory, and I filtered downloads from 3D Warehouse to near 50mb and > 150k polygons. Zoomed around in SketchUp and sent to LayOut and did the same. Performance was good.


Do they know you at the Apple Store? They see you walk in and greet you by name. Get you a cup of coffee and a chair? :slight_smile:


Hey, at least I don’t have to hack as bad as I used to have to in order to get it running. They won’t let you drag things into /Applications without having their credentials, but it did run from the dog installer. What I really wanted to test it on was one of those pretty 5k iMacs. This one just looked sad and dated sitting next to them. Like the one in my study.


Mmmmmm, that’s odd then. No idea why my Layout is so bad at zooming. 4GB GPU, i7 4.2Ghz and 40GB RAM. 5K Imac. It’s painfully bad.

Did those models have textures on?



Just tried that, downloading a 41MB file from 3D Warehouse. Now Sketchup is struggling with it! Killed Layout!

How much do draughting desks cost nowadays?! Getting thoroughly annoyed with this.