SketchUp Activation Authorization will not prepopulate serial number and authorization code

license
authorization
activation
activation_info

#1

After following these directions: https://help.sketchup.com/en/article/3000229 to authorize sketchup using a license, launching sketchup and clicking add license does not pre-populate the serial number and auth code.

How do I get it to pre-populate this information if I have already followed these directions. I’ve had 3 of my IT coworkers look at this and have been unable to fix this as well.


#2

Is it a license for SU2017 or is it a license for an earlier version?


#3

is there still an ‘advanced’ button on that page?

john


#4

It is licensed for 2017


#5

So you copied the license info from the e-mail to the clipboard?


#6

activation_info.txt should read ( in plain txt )

{
“serial_number”:“YOUR SERIAL NUMBER”,
“auth_code”:“YOUR AUTHORIZATION CODE”,
“allow_reactivation”:true
}
The last part should take care of that
Did you save that in the right folder?
(Hidden folder)
Windows - C:\ProgramData\SketchUp\SketchUp 2017


#7

I have copied the license info, and I have typed it in manually.


#8

Yup, I’ve got this exact thing, with my serial number and auth code in the right folder. It is still not pre-populating the fields.


#9

There is an advanced button, but nothing pre-populates from my activation_info.txt file.


#10

I not sure it should, otherwise people could copy/paste it etc…

after a restart is SU working in Pro mode?

john


#11

Sometimes an 0 is easily mistaken by O, depending on font (I and l are also famous for mistaken identity )


#12

Yeah, I’ve copied it into word and changed the font to make sure I’m not inputing the wrong information.


#13

it needs to be saved in plain text to be read as code, isn’t word rich text?

john


#14

That was only to make sure I was typing it right. The actual file is sitting in notepad.


#15

It is supposed to Pre-Populate with starred out information so that you can just click activate. It worked fine for 2015, says it should work fine for 2017, but it doesn’t populate.


#16

When I licensed my copy of SU 2017 Pro I copied the license info from the e-mail and then clicked on the Advanced button. It automatically read the clipboard.

Did you install SketchUp 2017 correctly by right clicking on the installer and then clicking on Run as administrator?


#17

Right, however, I need it to Populate from the activation_info.txt file as outlined here: https://help.sketchup.com/sv/article/3000285


#18

First two letters of serial are ?


#19

But did you install SketchUp correctly?


#20

First two letters are SH