Sketchup 6 second left click mouse delay


#1

Switched to a new computer and installed SketchUp Make. All functions work well except for the following:

  1. Once I make an object and triple click on it only the first click counts there is a 6 to 10 second delay before the mouse clicks take effect.
  2. When selecting an object with the select tool right to left or left to right it takes 6 seconds before you see the dashed box appear.
    I have run the following solutions:
  3. Run install Checkup and it passed all checks.
  4. Uninstalled Sketchup and reinstalled it.
  5. Uninstalled SketchUp and downloaded it again and reinstalled it.
  6. Switched to a new mouse.
    The graphics card appears to be an Intel UHD Graphics 630, GL version 4.5.0

#2

What is the graphics adapter in your computer. You entered “0” which doesn’t answer the question.

There are numerous threads on the topic of this delay. Two common issues. First failure to install SketchUp correctly using Run as administrator when right clicking on the installation file you downloaded. The other related to Intel graphics adapters and out of date drivers. Intel graphics are well-known for their lack of adequate OpenGL support.


#3

The graphics adapter appears to be an Intel UHD Graphics 630, GL version 4.5.0.


#4

Despite what it says about the GL version, Intel graphics drivers don’t tend to support OpenGL well. Go to the Intel site and install the latest drivers and see if that helps.


#5

https://forums.sketchup.com/search?q=Slow%20select

FWIW: most posts about the slow selection mention 7 seconds of delay, so there is some progress on the Windows side :grinning:


#6

(a) Please update the “Graphics Card” field in your forum profile. (Accessible from your avatar menu, top right menubar. Choose the gear icon, then “Profile” in the left column navigation list.)

(b) Latest Intel driver is dated 29-AUG-2018 …


(3) There is a patch for SketchUp 2018 to overcome the “slow select tool” issue … sorry, it is not available for SketchUp 2017.


I just got a new Windows 10 machine myself ~ 3 weeks ago. I yet have not needed to run the slow select patch.

But I am an IT geek. The first thing I did was have Windows update all the OS components. (Your profile seems to indicate the Win version as the initial “out-of-the-box” version.) Mine took a couple of update cycles and reboots but it is now up to version 1803.

I did have an issue where Win 10 decided to install an older graphics driver then I had installed direct from Nvidia, but I reinstalled an even newer driver afterward myself.

I have since tested all SketchUp trial versions that are supported under Windows 10, in the order they were released, … and have had few issues running any of them with either the integrated Intel UHD 630 or the Nvidia GTX 1060. No select tool delay. No apparent problems with Fast Feedback “on” as other Intel users have.

My only problem has been a lockup when SketchUp opens on the “secondary” display and that display is the internal notebook display, whilst an external monitor is set as the “primary” display. Reversing the Windows display numbers fixed the issue (along with a rigmarole of moving the SketchUp windows back to the “primary” display before revert the Windows display numbers.)


The other thing you can try is switch off Fast Feedback in SketchUp’s OpenGL preferences.