Shortcutkeys do not respond immediately in SketchUp

mouse
shortcuts
driver
evoluent
mouse_manager

#1

Hi there,

I’ve just switched to a brand new machine:

  • 17,3 inch Clevo P670RP6-G
  • NVidia GTX 1060 6GB vRam
  • Intel Core i7-6700 HQ CPU@2.6 GHz

I plan to use this laptop for modelling in SketchUp Pro 2017 and rendering in VRay and now I’ve encountered an usual problem. I usually use a lot of keyboard shortcuts to activate sketchup tools but this is not working properly… After activating any function or tool using a shortcutkey, the activated tool is not working immediately, I’ve to wait for about 2 seconds before the tool responds to mouse clicking. So once I hit a shortcutkey, the cursor icon changes immediately, Sketchup does respond to mouse movement, but doesn’t respond to mouse clicking for about 2 seconds. This delay really slow me down (and is also really annoying) so I really need this issue to be resolved.

Is anybody familiar with this issue? Does anybody know how to fix this?

This is what I’ve tried so far:

  • First of all I decided to test whether GTX 1060 is functioning the way it should (the manufacturer claims it does) and whether SU is using the NVidia GTX 1060 card as it should and not the integrated Intel graphic card instaed.
    I’ve used the Unigine Valley Benchmark to test the 1060 and it scores ok (as far as I can tell). Furhermore I did a FPS count while orbiting a huge SU-model using both (50MB, +1million polygons) the GTX 1060 and the Intel graphics card. The Intel card scored only 1-3 FPS while the GTX scored 30+ FPS. Considering both experiments, I would say the GTX is functioning properly.
  • I also experimented with different OpenGL settings: no improvements
  • Next I uninstalled all extensions. Once again, no improvements
  • Reinstalling SketchUp as administrator didn’t help either.
  • Last of all, I compared the performance of SU15 to SU17 on this machine. The performance is exactly the same. Both versions show the same delay.

Does anybody have any other suggestions? Any clue what might be causing the delay?

Thnx in advance.

Grtz,
Jan


Delayed tool availability when using shortcut keys to access tools
#2

Did you reinstall by selecting the installer exe file’s icon and right-click > context-menu > "Run as administrator"
Then choose “Repair”

Installing it any other way can cause issue - i.e. being the administrator or a user with admin-powers + double-click on icon is NOT sufficient…


#3

There are a number of topics already on tool slowdown caused by a recent Windows Update.
Do a search in this category (magnifying glass icon.)


#4

What happens if you activate the tools from the toolbar instead of shortcuts? What tools have you tried?

I’m thinking maybe sticky keys is enabled and interfere with the tool but I think that would only happen if the shortcut involves a key that makes the tool behave so differently it appears as there’s no response at all. Just an idea.


#5

Thnx for trying to help me. Yesterday I installed sketchup the way TIG suggested, sitting on a couch using the touchpad. After doing so, I opened Sketchup to see whether the issue was solved and it seemed to be functioning the way it should, finally!

To be sure, I connected the mouse to the laptop and once again I was experiencing the delay issue with shortcuts. So it wasn’t Sketchup nor the hardware which was causing the delay, but it turned out to be the mouse! Since it was functioning fine otherwise, I never even considered the mouse to be the problem. After reinstalling the mouse driver the problem was finally solved. It’s so simple if you know where to look… )

So PROBLEM SOLVED! Thnx for helping!


#6

What make and model mouse ?

What was the driver version that was bad ?

What was the driver version that worked ?


#7

The Evoluent Vertical Mouse 4 right, comes with some software named Evoluent Mouse Manager for reassigning functions to the mouse buttons. The Evoluent Mouse Manager was causing the delay. Uninstalling the Mouse Manager solved the delay issue.

I’m still able to use mouse for SketchUp without the EMM. However, I still would like to reassign some functions for the mouse buttons. So I contacted the Helpdesk of Evoluent about this issue, haven’t got a reply yet.


#8

This topic was automatically closed after 91 days. New replies are no longer allowed.