Sketchup performs commands after a 1-2 sec idle

I have just bought a new laptop (Lenovo Thinkpad p1 Gen 3 with Nvidia Quadro T1000 graphic card) with Win 11 installed. I have downloaded the latest sketchup pro on it. I have used sketchup for years now on my older laptop so I can work quite quickly. Now on this new machine everything works beautifully, the commands I give by shortcut buttons (zoom, orbit, select, push/pull etc.) do work, but when I switch from one command (eg. zoom) to another (eg. orbit) the cursor changes immediately, but I cannot effectively use the command (even if I click multiple times) for 1-2 seconds. Then it works without any issue, very smoothly until the next change. It is really frustrating, because I am an interior designer and I have to zoom and orbit etc. in models a lot and very quickly. And the funny thing is my older laptop does not have the problem even though it has no dedicated graphic card and is a much older model (Thinkpad x230). The same happens in the online version of Sketchup. I have been through updating drivers, reinstalling win 11, I also tried going back to Sketchup 2022, all the same… On the other hand, the render program Enscape works flawlessly on it, which is a more demanding application in terms of graphic card use. One more interesting fact: this laptop has a touch screen and if I do the commands on the screen with my fingers, they work immediately and very smoothly. Any ideas?

It would be interesting to see you SketchUp model. In most cases delays like you describe are typically caused by things like style settings, shadows, excessively detail components, very large texture images, and unused content. Optimizing the SketchUp model goes a long way to improving performance.

If I start a project from zero, it is the same, unfortunately. Even on the online Sketchup

Again, it would be helpful to see one of your SketchUp model files.

Have you updated the graphics drivers? Are you using a docking station?

I have updated the drivers. And no docking station. But it has nothing to do with overheating or overly large models - I have experienced these types of issues and it is something completely different. Because everything else works just perfectly, if I use the touch screen for all these commands, no problems. But I am used to using shortcuts and the trackpoint when creating models.

Oh, I just experienced something weird,I have tried my wive’s mouse (I never use one) and the problem is gone with the mouse. So only when I use the track point and the touchpad buttons… . What can it be? Because the curser changes quickly…

Maybe outdated track point/ touch pad drivers? Clearly not SketchUp if using a mouse fixes it. SketchUp really is designed to be used with a mouse. Maybe you should get one of your own.

Thanks for the tips, I am trying to fix the track point driver. This must be where the problem is.

1 Like

So, now that we narrowed it down to the touchpad/track point, I ran diagnostics straight from Lenovo’s support page. Updated drivers. Finally, I found out there was a delay setting in the windows for the double taps on the touchpad. Even though I did not tap on the touchpad itself but used the button, when I changed the setting for no delay, my original, frustrating problem disappeared. Everything is fine now, I continue to be a happy Sketchup user. Thanks!

2 Likes

I strongly recommend investing in a wheel mouse if you are not already addicted to another 3D navigation device like a 3D Connexion device. The wheel and the wheel button make zooming and orbiting while using modelling tools so much easier. I think the cheapest models start at something like $10.

2 Likes

This topic was automatically closed after 186 days. New replies are no longer allowed.