SketchUp 2024 Toolbars Language mix

Hello everyone
My SketchUp 2024 Pro mixes 2 languages (English and German) in the titles of the toolbars (only there). Neither the Windows language settings nor a new installation of SketchUp could solve the problem.
I had previously installed SketchUp with the German language pack by mistake.
Who can help me? Thank you very much.

this is why.
I observed the issue in SU23 already, people installed SU in english and later corrected to french, but the drop down menu remained in english.
german in your case.

I’m sorry, I don’t bring a solution, I’m guessing there is a preference file that need to be deleted somewhere, I’m simply piggyback riding your thread to see what the solution is.

and no, running the installer as admin and picking the language option doesn’t fix that. That’s how I switched from english to french and how I ended up with the english drop down menu in the first place

There is certainly a file somewhere that lists the titles. But which one?

The toolbar settings are saved in the PrivatePreferences.json file located at:

  • %LocalAppData%/SketchUp/SketchUp 2024/SketchUp

But I see only the extension toolbar names are in normal text.

You can try deleting the whole file whilst SketchUp is closed, then it will be regenerated upon next application start and shutdown.

If this does not work ...

If this does not work, completely uninstall SketchUp and all language packs, restart computer, the reinstall with only the default English language.

1 Like

Hi Dan,
This exactly solved my problem. Thank you very much!
Kind regards

1 Like

Then, you have to mark Dan’s post as solution, not yours… :wink:

Thanks. Newbie here…

1 Like

You’re welcome, but I gave two possible solutions. Which one worked?

Deleting the Private.Preferences.json file worked fine. After restarting SketchUp 2024 every thing was correct.