Sketchup 2023 Generate Report windows doesn't pop up anymore

Hy Everybody, i need help in fixing this bug:
All is in the title, Generate Report windows doen’t pop up anymore,
no pop up at all, no failure message, nothing at all…

my version is sketchup2023, my os is Windows 10
Please Help me!
I need this function working again.

Generate Report works fine for me in SketchUp 2023. Did it work in 2023 before and only recently quit working? Do you have any sort of firewall setting that might prevent it from working?

First thing I would try is repairing the SketchUp installation. Close SketchUp and LayOut, find the installer in your Downloads folder or get the latested one from right click on the installer and choose Run as administrator. If prompted, choose Repair. After that try again with Generate Report.

Hard to know what could be happening, but you need to be connected to internet to be able to use the generate report feature.

@yohann.poulmarch try this:
After you select Generate Report, hit Alt+Spacebar and then select Maximize from the lil menu that pops up. Similar fix I’ve seen on this forum for missing Preferences or Model Info windows, although usually you select Move and then click and drag to get those back into view. Move did not work for me with the missing GR window though.

1 Like

A colleague had this happen to them, and the usual Alt-spacebar, M, arrow keys, didn’t work. It looks like the generate report and live component configure don’t have that menu.

For him, the problem was that he had been using two monitors, and now was on one. The missing windows were opening on the other screen. As the windows don’t have the upper left menu, they can’t be retrieved.

So, either connect to your second monitor again, or try Preferences, Workspace, Reset Workspace. If that doesn’t work, the preferences file may need to be regenerated. In File Explorer paste in this path:

%LocalAppData%\SketchUp\SketchUp 2023\SketchUp\

Close SketchUp, then in that folder rename or delete PrivatePreferences.json. Open SketchUp and see if the windows have come back.

If the Alt+Spacebar, M, arrow keys doesn’t work, deleting Private Preferences and restarting SketchUp should. It will also require redoing all of the toolbar positions. An alternative would be to open the file in Note Pad or Word Pad and edit the location of the Generate Report dialog. It’ll be near the end of the json file. Mine is shown below and the dialog opens nearly centered on my display. Try the same numbers and save the changes. Then open SketchUp and try Report Generator again.

  "WebCommonDialog_Generate Report": {
        "Height": 768,
        "Left": 269,
        "Top": 144,
        "Width": 1024

They do, actually, sometimes, a restart is necessary for the Live component dialog. Then, you know for sure the focus is on that dialog ( It needs to connect to the server, so the focus is in that dialog). For the Generate Report dialog, choosing it the second time from the file menu will make it disappear and therefore looses focus as well…
Or perhaps it’s the OS language, for the Dutch language it ‘R’ after pressing Alt + Spacebar. So make sure you get the right combo (Try with the main Window of SketchUp to see the options)


Hi! I also experiense this problem rather often, especially with large models. Yesterday I tried all the tricks mentioned in this thread(until 1 october 23), but was never able to get the report-dialog box to show.

Is there an extension than can do this? or is an earlier version of Sketchup more reliable regarding this?

I would delete the SketchUp browser cache if you are having things happen with generate report :

Quit SketchUp/Layout
paste this into an explorer address bar and delete the webcache folder.
%appdata%/sketchup/sketchup 2023/

Go back to SketchUp again and see if it now works

You also need to check if the Dynamic Components extension is enabled in the extension manager.


Thank you for your reply! Do you mean that I should delete the entire folder included the folder-icon? Delete this:

Best regards

Yeah Delete the whole folder that starts with the name webcache

Thanks again, your tip solved the problem! The “Generate Reporte” - dialogue box showed up imediately after I had deleted the webcache!

1 Like