"Generate report " Wont open

Hello everyone, in my office we use in 4 PCs Sketchup Pro,but just in one of them , out of the sudden, the generate report window doenst open. But in the other 3 it works fine.
We have tried everyting, check out in the task manager, check if its a web problem, change the licence, insert a shortcut with the keyboard, trying different files everything, it wont open…

Any ideas of what can be done?

If the option is missing , then it might be that the dynamic components extension isn’t loading - check that is still there.

You could also go to this folder

%AppData%\SketchUp\SketchUp 2023\

and delete the web cache folder to refresh it

its still there the dynamic components extension, i deleted the cache files and still nothing:/ should i re-install?

hello, have you tried resetting the workspace ? (window > preferences > workspace)

also, if you have multiple screen, unplug the additional ones, and relaunch sketchup

does the problematic machine have one screen or more ?

on multi screen machines, sometimes the windows kinda vanish outside. meaning the tool works and opens, but hides outside of your screen.
you can try this

it has 2 screens indeed, BUT we have tried to disconnect one of them and the problem continues. now he went to lunch as soon as he returns we try that sequence of keys.update: we tried, yet nothing, i am starting to think that its not a window problem, instead is related to the software itself, as it tries to “load” something but then nothing.

Also my colleague has had few bug splat crash recently ( i mean today) using dynamic components…

I had problems today with dynamic components, I was in a class showing how to create a dynamic components and the html dialogs didn’t work. I had to change from SketchUp 2024 to 2023 to continue the class.
I don’t know why Trimble is not updating SketchUp 2024 with a new release.

Try opening the ruby console and pasting this:

ObjectSpace.each_object(UI::HtmlDialog, &:center)

It helped me with lost html windows

MAGNIFICENT! it worked! thank you so much

1 Like