Sketchup 2018 Pro on a Surface Pro m3 not working (anymore)


#1

I don’t know what happened but SketchUp was working just fine until recently. SketchUp seems to still open files or create a new file just fine but I can’t see it. I can select a tool (such as the line tool) then click once and drag it around the screen and see the following:

My graphics drivers are up to date and so are Windows 10 and SketchUp 2018. I tried using the CheckUp tool and it told me Sketchup was ok. Reinstalling SketchUp did not fix the problem. Restarting my surface did not fix the problem. A friend with the same or a similar surface is having the same issue with SketchUp 2018 so I suspect a W10 update may be the culprit.

I have not tried uninstalling recent updates yet (and setting my connection to metered to prevent future updates) since I don’t know if that will work and Windows takes ages to update sometimes.


#2

Screenshot%20-%2010_4_2018%20%2C%204_07_40%20PM

Typically those “Some Garbage” graphics cards have difficulties with OpenGL and what you describe isn’t unusual. The same applies to the Intel Graphics adapters that are commonly found in Surface Pros. Since the problem has recently started (SketchUp 2018 Pro evidently did work at one time) you need to look at what has changed. There have been no changes to SketchUp 2018 Pro so that’s not the issue. Very likely it’s the drivers for your “Some Garbage” graphics card. If they are up to date and the problem persists, then maybe roll back the graphics drivers to the version that did work.


#3

Some%20Garbage

As far as I can tell only W10 has changed. This malware decided to update recently after I accidentally connected to a new network that I forgot to set as a metered connection. I guess uninstalling updates until SketchUp works again is my only option. Thanks for trying.


#4

As I said, you need to undo what has changed. Intel Graphics are notorious for poor OpenGL support.

Why don’t you update your profile with the real graphics card information? “Some Garbage” isn’t helpful at all.


#5

unticking ‘Use fast feedback’ in [Window]->Preferences->OpenGL will help, sometimes…


#6

THANK YOU MIKE!! I was having the same problem as Sketchy sketch above and your tip WORKED! Right before a big meeting, thank you for saving the day![quote=“MikeWayzovski, post:5, topic:78368, full:true”]
unticking ‘Use fast feedback’ in [Window]->Preferences->OpenGL will help, sometimes…
[/quote]