Sketchup 2018 on macOS BigSur - no internet connection error

Hi there everybody,

I work with Sketchup Pro 2018 on macOS BigSur.
Since about some weeks I have the problem, that Sketchup is no longer able to connect to the internet.
This is weird because my Internet connection works like a charm and I haven’t changed anything for a long time. I also tested different locations with all kinds of network settings, but it doesn’t help.

Sketchup brings already an error message on the startup screen and it fails to connect to the license server or to the warehouse etc.

I tried to change the server that Sketchup uses to check if the internet connection is established. According to some support document the server address can be edited in the file user/Library/Application Support/Sketchup 2018/Sketchup/PrivatePreferences.json

I found this file but the line “OnlineTestURL”: is missing. If a add it manually to the preferences file it doesn’t help.

Does anybody know how to fix the problem and get connected again?

Thanks for any advice
querbalken

P.S. A few days ago I was in Italy for a few days and there Sketchup did not show the connection error.

The license server and 3D Warehouse use particular ports, that you may be blocking. Can you get to 3D Warehouse in a web browser?

Are you able to use your phone as a hotspot, to see if that works ok?

Very good idea to test…

  • 3d warehouse via web browser is working.
  • iPhone as a hotspot doesn’t help with Sketchup (3d warehouse via web browser works as well)

Well the Test-idea was good… but the Problem still exists.
Has anybody an idea?

Do you have German language installed? I remember one case where it didn’t connect for licensing purposes, installing the English version worked ok…

Yes, it’s the german version. English version would be ok, but where do I get it?
If I log in at Trimble I do not find any Sketchup 2018 version for download.

Try here:

Thank you. I tried both - reinstall the German version and installing the English version.
Unfortunately it didn’t help.

Any other suggestions?
Thanks a lot querbalken

I’m not sure what the macOS equivalent is, but I know (on Windows 10) right click>run as administrator (on the SU installer)>repair option usually works for me.

@colin might know the macOS equivalent.

There is no macOS equivalent and no need for one. Install issues on Mac usually result when a user runs the app from a wrong location, for example directly from the distribution image or by copying the app from the image to somewhere other than the applications folder. There have also been issues when an old file isn’t cleared out by the installer and has to be deleted manually.

1 Like

FYI I moved the topic to the Tech Problems category.

Okay thanks Steve.

@querbalken have you tried running SU from another folder? If not then I have no idea.

I haven’t tried to run Sketchup from another folder because since I purchased it 2018 it worked like a charm until a few week ago. I haven’t changed anything since then.

Fort test reasons I tried it on several machines with different macOS versions and in several different network environments. - All the same. No internet connection.

So I was wondering if there was any problem with the Trimble Services?
Is there any way to check this, maybe by binging the servers? Or changing the addresses of the servers like it is described in the support document for connection problems.
Like I mentioned I tried the latter by changing the Sketchup/PrivatePreferences.json but I didn’t find the line for the “OnlineTestURL”: there.

Apple dropped OpenGL support and is pushing it’s updates automatically. A few weeks ago, they pushed out 11.3.
That might be the problem.
SketchUp 2018 is not gonna be updated, for sure.
If downloading in the browser works, set up a folder and in the component panel, choose ‘Open a local collection’ and refer to that folder.

Does Apple push their updates also to quite old macOS versions like Catalina? I’m asking because I have the connection problem also on an older machine that ist running Catalina.

Besides the plugin store problem there is also the problem, that I am not able to activate or deactivate licenses without connection to the Sketchup Servers. I haven’t found a workaround for that by now.

Try to delete the webcache folder
~/library/SketchUp/SketchUp 2018/

And the plist file of SketchUp inside this folder:
~/library/Preferences

1 Like

Coincidently, I’ve had the same issue occur around the same time. It’s affecting more than one machine now and it’s quite odd. I can access the internet through SketchUp via the Upload model function of the warehouse, but that’s it. So I know it’s connecting to the internet, it’s just not functioning correctly.

Both computers running SU2018 on Win10

See if my post here helps:

https://forums.sketchup.com/t/sketchup-thinks-you-dont-have-an-internet-connection/170862/4

This is BRILLIANT! Fixed everything!