Sketchup 2018 crashing on Startup

crash
sketchup
startup
plugin

#1

Hi All,

I have 2018 Pro for a couple of days now running fine. Installed Vray 3.6 and a few extensions but now when I go to open it brings up the error message below and then closes.

Does the same on Pro 2017 but then works???

Any advise?

Cheers

Load Errors
Error Loading File C:/Program Files/Chaos Group/V-Ray/V-Ray for SketchUp/extension/ruby/init.rb
Error: #<StandardError: Failed to initialize V-Ray>
C:/Program Files/SketchUp/SketchUp 2018/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in require' C:/Program Files/SketchUp/SketchUp 2018/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:inrequire’
C:/Program Files/Chaos Group/V-Ray/V-Ray for SketchUp/extension/ruby/init.rb:1:in <top (required)>' C:/Program Files/SketchUp/SketchUp 2018/Tools/extensions.rb:197:inrequire’
C:/Program Files/SketchUp/SketchUp 2018/Tools/extensions.rb:197:in load' C:/ProgramData/SketchUp/SketchUp 2018/SketchUp/Plugins/vfs.rb:26:inregister_extension’
C:/ProgramData/SketchUp/SketchUp 2018/SketchUp/Plugins/vfs.rb:26:in <module:VRay>' C:/ProgramData/SketchUp/SketchUp 2018/SketchUp/Plugins/vfs.rb:4:in<top (required)>’


#2

Contact ChaosGroup who should know what to do.


#3

Hey,
I have the same problem. Did you manage to solve this?

Cheers


#4

Same problem here, too. Chaos has been contacted and opened a ticket to look into it.


#5

Hi All,

I have contacted Chaos group and the problem is partially solved. Basically its 3rd party plugins that are causing the issue.

You need to un-install vray. open Su18 turn off all plugins via the plugins manager. close Su down. Re-instal vray and you can reopen Su18 and turn back on the plugins until you find the plugin that is causing the crash. Basically trail and error of un-installing and re-installing vray.

I have done for mine and its still temperamental but is working.

Once you do let chaos group know and they can solve for the next release.

Cheers


#6

Hi,

I had the same issue. The problem can be solved by installing sketchup 2017 pro and then previous version of vray (3.4). For me is sucks, I have license only for 2018.

Update:
I removed my national language version, then installed SketchUpPro-en.exe, reinstalled Visual Studio Redistribute and it solved the problem.

Best regards.


#7

Just in the plugin folder find su_dynamiccomponents.rb (open it with some ruby editor in the plugin store) and add to the beginning of the code: "UI.start_timer (5, false) {"
and at the end of the code: “}”. It will load DC plugins after all other (5 = seconds, false) plugins, as well as Vray. So the Vray load will be normal and you will be able to use all the benefits of sketchup and vray.
Plugin folder on win: C:\Users\User name\AppData\Roaming\SketchUp\SketchUp 2018\SketchUp\Plugins


#8

I have the same problem. Can you please create screenshot to understand where exactly I need write this code: "UI.start_timer (5, false) {"
and at the end of the code: “}” ?

And why do you think that the problem is in Dynamic Components? In extension manager I turned off DC but vray still crash the SU startup.


#9

Disable DC in extension Manager, make a scene and do a save, it does not matter what scene, the save part is important.
Close and reopen sketchup to see if still disabled, close sketchup again.
Reinstall vray


#10

Vray has somehow been involved in the DC plugin since the very beginning. Normally in SketchUp can happen that the two plugins get into a fight with each other. So, when it comes to vray I haw suspected at the DC.


#11

Ok. I disabled “Dynamic Components” and “su_dynamicomponents” in Extension manager then I saved my skp file. Then I opened it again and in Extension manager I saw that “Dynamic Components” is disabled but “su_dynamicomponents” is enabled. Is it ok? I didn’t anything in SU so I closed it and after that again opened and now both “Dynamic Components” and “su_dynamicomponents” plugins is enabled.
Vray is unistalled.


#12

Thanks, I will try it.


#13

Did you create a scene?


#14

I have my standard scene (named as “Work”) in my template what I use in startup, therefore I didn’t create new scene I just updated my “Work” scene and saved skp project.
Screenshot_2


#15

“su_dynamicomponents” is a surplus. You probably did something in the plugin folder.


#16

You I right, thanks. I simply created a copy of su_dynamiccomponents.rb in plugin folder to try use code (UI.start_timer (5, false){) in original file and forgot remove copy from plugin folder.


#17

Did you change the code? Is it all right now?
Does Vray and DC work together now?


#18

Not yet, wait a bit.


#19

No. It doesn’t work. I wrote the code to sum dynamic components.rb as you shown in screenshot. May be the problem is in another plugins.




Screenshot_4


#20

For now it works with 1001 bit tools and DC! SU doesn’t crasched. I will enable another plugins one by one to see what makes the problem.