SketchUp 2017 materials library?

Hi, I’m new around here. I’ve tried to find an answer on Google, but to no avail.

So, I’ve been using SU Make 2016 until recently because it seemed to run smoother. But after upgrading my hard drive this last week, I re-installed Windows 10 and decided to try working with SU Make 2017. Well, now I can’t seem to find the Materials library in 2017. In 2016 it was in c:\Program Files\Sketchup\Sketchup 2016\Materials but for 2017 version no such folder exists. In SU, going to Window > Preferences > File Locations shows the default drive path for materials is c:\Users"Me"\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Materials, but the folder is empty. The default material library shows up in SU even though the folder is empty. Also, any materials I save to that folder do not show up in the materials tray.

Where is the default material library located and how can I save new materials to use in SU?

Thanks for any help.

You don’t want to save your custom materials to where the OEM SketchUp materials are saved. If you ever had any reason to reinstall or repair the installation, you could lose them if SketchUp overwrites the folder. Instead they go into the Materials folder in User/AppData like you show. Then when you open SketchUp, that folder should show in the drop down list. You can add your materials folder if you need to by clicking on the Details menu and selecting Open or Create… The Details menu is accessed via the right-pointing arrow to the right of the drop down in the Materials panel.

Make sure that you properly installed SU2017 by right clicking on the downloaded installer and choosing Run as administrator. If you installed by any other method, repair it before you proceed with the materials stuff. Find the installer, right click, select Run as administrator, then choose the Repair option. Do this of course while SketchUp is closed.

Thanks! Previously (v2016) I had just saved custom textures to the OEM materials folder because that’s where it said the drive path was. I saw the Open or Create Collection options in the materials tray but I didn’t know if doing that would override the OEM materials and erase them, so I wanted to be sure before opening a new materials collection.

No. Doing that won’t override the OEM materials. That’s actually part of the point of putting the user’s Materials files where they put them. Normally also the location for the OEM files is secured by the operating system to prevent unauthorized monkeying around (malware style)

The other cool thing with this comes if you uninstall SketchUp 2017, you won’t remove these files. The Uninstall routine doesn’t touch the User/AppData folders.

Put them in subfolders (of this folder) and they’ll be automatically enumerated local collections.
The same for other resources folders (styles, components, classifications, etc.)

The changes for SketchUp 2017 are listed in it’s Release Notes.

Dan makes a good point that I should have done myself. Organize your materials into sub-folders within the User Materials folder. This will also make them easier to work with. I create a lot of my own wood grain textures so I divide them up by species.

Thanks for the help, I got everything worked out now.

how to solve your problem, i have the same issue material jpeg not showing in material edit