Help with custom materials folder location (driving me nuts)


#1

I am missing something super basic here, if someone could please help I would really appreciate it. I have many custom made and downloaded materials in many different types of folders. It seems pretty straightforward to try and get SU Pro 2018 to look at the folder I want. I go to Preferences>Files>Materials and select the folder on my computer where I have all of my materials. But when I do this the materials browser doesn’t show what is in the folder that I have on my computer. I am at a loss, what am I missing?


#2

Try to select one level up.


#3

Hello, you have to create SketchUp materials and save those as .skm. A folder with just images won’t show up as material library automatically.


#4

Tried and it did not change what is displayed in the materials window

Yes, I’m aware of this. The materials are all saved as .skm. What is the most strange is that it is the folder structure that I’m pointing to in the Preferences is not even showing up. What I mean is that I am pointing to a folder called “Materials” and within that folder are many subfolders, it doesn’t even show these folders. It just seems to show the default folders.


#5

Hard to tell, it should work, are you selecting the folder itself or the shortcut/favorits?
Try this: make a new folder on your desktop and select that one in the Preferences.
If that doesn’t work, try to reinstall by rightclicking on the installer file and choose ‘Run as Administrator’

Edit: also open this new collection by right clicking on the blue detail icon in the material panel


#6

Try to create a collection in the materials tab in the SketchUp tray.

Default Tray -> Materials -> Details -> Open or create a collection…
Then point to the folder with your SketchUp materials and a library will be added with the name of the folder. You can add as many folders with sub-folders as you want.


#7

The last couple posts have made me wonder if what I am expecting SU to do is not what you all are expecting. Take a look at the screenshots to see what I am seeing. To me it seems like the SU materials window drop down should match the folder that you select in the preferences dialogue. Can I only get my folders to show up in the favorites section? If so what’s the point of setting the path in the preferences section?

{oops, here are the screen shots}

!


#8

Did you click the folder button to open the file?

Another place textures are stored is inside the package contents of SketchUp. Don’t blame me if you mess up the program though…


#9

… or what the software itself is expecting (because it is programmed to do something else) ?

Except that it has never done this, and the User Guide has never claimed that it does this.

Those paths in the Files panel of the Preferences dialog only serve as the default path for the system Open and Save file dialogs. See the table here for specific information for each path …

So to test:

  1. Paint something in a model with one of the distro’d materials.
  2. Then switch to the “In Model” materials collection.
  3. Right-click on that materials (or any within the model) …
  4. … and choose “Save As…

The system Save panel dialog will open in the folder path you specify in Preferences > Files.

If you instead choose “Export Texture Image” from the right-click context menu, you’ll notice that the system Save dialog opens in the one of the other paths set there. (I notice it bugly opens in the “Watermark” path rather than the “Texture” path in SU2016.)

The same holds true for the other paths concerning components, etc. Whenever you need to open or save a file these paths are used. (It is sort of a override of Windows built-in MRU paths, which always take you to the last path you saved a certain file extension type. These overrides allow a stable place you can expect the dialog to open at. Sometimes desired sometimes not.)


If you want the Materials browser to automatically populate your Materials inspector panel, place your materials subfolders in your "%AppData%/SketchUp/SketchUp 2018/SketchUp/Materials" folder.

If you are an administrator, you can create a symbolic link in the parent directory that points at some other “Materials” folder. (This makes sense as the SKM files are really version independent zip archives. I would prefer to have support for base folders up a few levels under the "%AppData%/SketchUp" folder that are not version dependent and do not need migrating each year as we upgrade.)


Otherwise for now you’ll need to create a collection / or add to favorites.


#10

Thanks, I see now the purpose of the file path. I have an (incorrect) memory of being able to get SU to do what I described in previous versions of the program. I must just have confused this with something else.

I was trying to avoid this just to make it a little easier moving from version to version but I suppose it’s not a very big deal. I will just copy over my materials or access them via. the favorites.

It always annoys me when programs don’t allow you to remove or hide certain features. My collection of materials is the one I want to use, having the dialogue show me the stock materials menu just takes up space and time.

Thanks for the help all.


#11

Ugh, this material thing just continues to be difficult. I resigned myself to using the “add collections to favorites” option but am getting an odd result.

I recently changed all the names of my wood materials to so they would be grouped by similar traits to make selection easier. Basically I just added a prefix to each of the texture names. SU is behaving like there is some kind of cache I need to clear. It is displaying the names without the prefix for some reason. I’ve tried changing the folder name, restarting the program, restarting the computer. Still same result


#12

Your problems stem from incorrect assumptions.

No you didn’t. You changed the SKM filename, not the material’s name. The SKM is a zip archive with XML files and images inside it. The “specifications” of the material (including it’s display name) are in one of the internal XML files within the SKM archive.


Material Names Not Updating
#13

Ah ha! Thanks, I definitely wouldn’t have guessed this. I’m bummed that I took all the time to rename all the .skm files. Is there any easy way to change the material name to the file name? It’s not that big of a deal but each little thing that makes my work flow more efficient helps shave real time over the long haul.


#14

I think we can come up with a Ruby script to do it.

EDIT (1hr & 40 mins later) …I posted my version of the task here …


#15

Doesn’t @john_drivenupthewall has such a script written already?


#16

I don’t know. I know TIG had published a SKM Toolkit over at SketchUcation.


#17

Okay I posted my version of the task here …


#18

Wow Dan, thanks for taking the time to do this. Above and beyond. I will try it as soon as I can.