SketchUp 2017 and Mac OS Ventura

I have been perfectly happy using SketchUp 2017 for my personal work (architecture, home repair, woodworking design, etc.), but I just installed the Ventura operating system and I am now unable to open SketchUp 2017. The system claims it is damaged and should be thrown in the trash. Is there something about the Ventura OS that makes it impossible to run SketchUp 2017? Is there any solution to this other than purchasing SketchUp Pro?

It shouldn’t really be a surprise that five year old applications don’t work on an operating system released a few weeks ago. Even SketchUp 2022 doesn’t officially support Ventura, yet. It’ll probably be SketchUp 2023 that does support Ventura.

It is safe to say that SU2017 will not get any updates so your options would be to upgrade to SketchUp Pro, switch to using the web based version, or roll the operating system back.

I don’t know why you are getting that message. SketchUp 2017 will launch on my 2019 MBP running Ventura 13.1 However, I have found it to be somewhat unstable. It will sometimes crash unexpectedly after running for a while. So, I use it only for a quick check whether the extensions I have written will still work. Since it is no longer available from Trimble, I suppose the need for this check will start to fade away.

Thanks for the responses. I’ll either upgrade to SketchUp Pro of downgrade my OS back to Monterey.

Hello. I read this post and decided to offer my two cents. I’m new to SketchUp,However,
I’m running on a MacBook Pro, M1, 8GB Ram, etc etc. Ventura 13.0.1 OSX. I purchased SketchUp Pro(Subscription) and the software freezes all the time. I even tried starting in Rosetta, and it still freezes up.


Thanks. I did upgrade to SketchUp Pro rather than downgrade the operating system. I have only tried using SketchUp Pro briefly, but it seemed to run OK. I’ll post something if it freezes on my when I am trying to use it for a real project. I am running Ventura on a 2017 iMac using a solid state external drive for the operating system.

Richard Patterson
Cell: 310-709-6786

OK, I started to model a small box with SketchUp Pro 2022 on my iMac running Ventura. It took me a while to understand the difference between using Layers and using Tags, so some of my minor problems may just be that I am still learning to use the newer version. The main issue I have so far is that the response to keyboard entries seems erratic. I have noticed that holding the option key does not always copy the object when I move it. It does sometimes and I cannot figure out what the difference is. I have also noticed that pressing M does not necessarily switch to the Move tool.

Oh…I tried reading the user guide for the move tool. I did not know I should just tap the Option key rather than hold it down.

It’s always a good idea to read the release notes because they describe additions and changes in tools. And if you miss a few versions, you need to to read through the release notes for those intervening versions, too.

There have being some changes since skp 2017, a useful one is the cloning option with the move tool, just press the option key twice and a small icon will appear next to the tool, also the eraser tool has some changes you don’t need to hold option or shift to smooth or hide edges, just press them once, also with layout there have been some changes and more features had been added, my favorite one is the control of sketchup tags on layout, you can change the style of a line, width or color of an specific tag and it will change in the same viewport. You should really take your time to be familiarized with all the new features and changes.

Yes, thanks.