Sketchup 2016 pro version installation stuck

I have download sketchup 2016 and trying to install but always its stuck on “registering modules” I have tried 7-8 times but still same its stuck there only i have restart and shutdown few times but result same stuck. i want to finish that process and use sketchup pro 2016. Anybody can give some solution

have you tried “Run as Administrator”. right click on the .exe

No ok i will try that option also and tell u

No result is the same i have tried with “Run as Administrator” but its stuck there at end only. Plz any other options from the masters.

Ok, i googled “Registering modules” and many programs and people have this issue. glanced thru and looks like sometimes its a firewall issue or needing to defrag the registry. must be your Windows so maybe look into registry issues and firewall…

Sorry i cant help any further.

the installation stuck there but good news i got the 3 icon (Sketchup, layout and style builder) on desktop. i stop the installation and restart my pc. i open the sketchup 2016 bingooooooo it works fine.:smiley: