SketchUp 2016 plugins missing after Ruby Script was saved in Plugins folder

Hello,
I tried to follow the tutorial in the link below using Mac:
http://www.sketchup.com/intl/en/developer/docs/tutorial_geometry
I created a Ruby script called stairs.rb and saved it in the folder called Plugins in this path:
Libary/Application Support/SketchUp #/SketchUp/Plugins/stairs.rb

The following is the code in stairs.rb:
# First we pull in the standard API hooks.
require ‘sketchup.rb’

# Show the Ruby Console at startup so we can
# see any programming errors we may make.
SKETCHUP_CONSOLE.show

# Add a menu item to launch our plugin.
UI.menu(“Plugins”).add_item(“Draw stairs”) {
UI.messagebox(“I’m about to draw stairs!”)
}

But after restarting SketchUp, I can’t see Plugins anywhere in the Menu list at the top. Where can I find that Ruby script that I wrote. Very frustrating. I can’t follow the tutorial.
Can anyone give any suggestions?

And another thing too, the path for OS X is:
/Users/<your_mac_user_name>/Library/Application Support/SketchUp [n]/SketchUp/Plugins
What is this [n] in SketchUp [n] for? Is that supposed to be named like this?
SketchUp [1]
or
SketchUp 1
or
SketchUp #
?
I created these folders manually inside the Library/Application Support, is that correct way to do it ?

Thank you,
Katherina

the [n] is for the SketchUp version number. i.e. 2016

no, SU already creates the correct folder for you with the correct version number in it’s path name…

in the menu it’s now called ‘Extensions’ not ‘Plugins’…

it only appears if you have a plugin in that folder…

john

Hey John, you saved my day!!! Thank you so much.
That was the problem, the naming of the folder, the folder should be named:
Sketchup 2016
not Sketchup [n] or SketchUp #, or anything else. These articles didn’t give helpful information at all:
https://help.sketchup.com/en/article/141451

And why can’t this article be written clearly that [n] stands for the year of the SketchUp model version?
http://www.sketchup.com/intl/en/developer/docs/loading
I spent the whole day trying to figure it out!

Now I can see ‘Extensions’ at the top in the Menu list, and when I clicked on ‘Extensions’, the plugin ‘Draw Stairs’ appears in the list, and when I click on it, it shows the dialog, yay!
And I can tell you that when I installed the software, there is NO path or folders created automatically to contain ‘Plugin’ folder! I can assure you about that, so that’s why I had to create it manually. A bit unreliable.

Anyway, thank you so much for your help.

Regards,
Katherina

Most likely you were looking in the wrong place. Extensions you install are put in your own ~/Library folder, that is

/Users/<your name>/Library/Application Support/SketchUp 2016/SketchUp/Plugins

where <your name> is replaced by your user name. They are not put into the system /Library folder. SketchUp does indeed create the folder when you install the first extension, not when you install SketchUp itself.

Finder hides ~/Library by default, so to see this folder you have to either change Finder options to reveal the folder or use Go->Go To Folder on the Finder menu.

They are created ‘on demand’, so if you run SU once then ‘Plugins’ folder will be made as SU copies it’s own plugins into it…

that won’t give you the menu item as the su_plugins live in other menus…

john

Hey Steve, you are right! The ‘Library’ folder is hidden, I use Go -> Go To Folder on the Finder menu and I discovered that hidden Library, and the rest of the Application Support/SketchUp 2016/SketchUp/Plugins path. (I didn’t know that…) I have deleted the folders that I created yesterday and placed the stairs.rb file in the Plugins folder and now it appears in the list of ‘Extensions’ in the Menu at the top.
Thank you all for your help, appreciate that.
:slight_smile: